aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/lib/devtool/build-image.py
diff options
context:
space:
mode:
authorEd Bartosh <ed.bartosh@linux.intel.com>2015-08-30 18:41:38 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-31 11:36:57 +0100
commit82c6452ca953eb32e2919d9f9e64497a15212be5 (patch)
tree572e9a8b5707348ec71c6e2bcecec510436d67e2 /scripts/lib/devtool/build-image.py
parentf719e956a6263784963b6ae9514030a1a1dc2aeb (diff)
downloadopenembedded-core-contrib-82c6452ca953eb32e2919d9f9e64497a15212be5.tar.gz
devtool: build-image: remove <image>.bbappend
Removed <image>.bbappend before generating it again as it may cause tinfoil to fail due to its wrong content. It's safe to do as <image>.bbappend is regenerated anyway. Signed-off-by: Ed Bartosh <ed.bartosh@linux.intel.com>
Diffstat (limited to 'scripts/lib/devtool/build-image.py')
-rw-r--r--scripts/lib/devtool/build-image.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/lib/devtool/build-image.py b/scripts/lib/devtool/build-image.py
index 563563b3e7..5bc82134c1 100644
--- a/scripts/lib/devtool/build-image.py
+++ b/scripts/lib/devtool/build-image.py
@@ -50,6 +50,11 @@ def build_image(args, config, basepath, workspace):
appendfile = os.path.join(config.workspace_path, 'appends',
'%s.bbappend' % image)
+ # remove <image>.bbapend to make sure setup_tinfoil doesn't
+ # breake because of it
+ if os.path.isfile(appendfile):
+ os.unlink(appendfile)
+
recipes = _get_recipes(workspace, config)
if recipes:
with open(appendfile, 'w') as afile: