aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/lib/bsp/help.py
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2013-03-11 22:19:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-17 23:10:28 +0000
commit5edc7af428cccfbf53780fc98ed1685b655f43d1 (patch)
tree8a2d19445c3761229cae00d52dcb17d14ee0ea15 /scripts/lib/bsp/help.py
parent2518215438119804290aa8149936ebde0fcc89d3 (diff)
downloadopenembedded-core-contrib-5edc7af428cccfbf53780fc98ed1685b655f43d1.tar.gz
yocto-kernel: add support for creating recipe-space kernel features
Add a yocto-kernel command allowing users to create a recipe-space kernel feature local to a particular BSP. The new feature is subsequently available for the normal feature addition and removal yocto-kernel commands used with features defined in the meta branch of linux-yocto kernel repos. (From meta-yocto rev: 13abcd93b9e1591bc45ff5f9eb17b8feb9ac9ae5) Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/lib/bsp/help.py')
-rw-r--r--scripts/lib/bsp/help.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/scripts/lib/bsp/help.py b/scripts/lib/bsp/help.py
index 91de60017e..d7c0360a7a 100644
--- a/scripts/lib/bsp/help.py
+++ b/scripts/lib/bsp/help.py
@@ -388,6 +388,7 @@ yocto_kernel_usage = """
feature rm Have a BSP stop using a feature
features list List the features available to BSPs
feature describe Describe a particular feature
+ feature create Create a new BSP-local feature
See 'yocto-kernel help COMMAND' for more information on a specific command.
@@ -752,6 +753,41 @@ DESCRIPTION
"""
+yocto_kernel_feature_create_usage = """
+
+ Create a recipe-space kernel feature in a BSP
+
+ usage: yocto-kernel feature create <bsp-name> newfeature.scc \
+ "Feature Description" capabilities [<CONFIG_XXX=x> ...] [<PATCH> ...]
+
+ This command creates a new kernel feature from the bare config
+ options and patches specified on the command-line.
+"""
+
+
+yocto_kernel_feature_create_help = """
+
+NAME
+ yocto-kernel feature create - create a recipe-space kernel feature
+ in a BSP
+
+SYNOPSIS
+ yocto-kernel feature create <bsp-name> newfeature.scc \
+ "Feature Description" capabilities [<CONFIG_XXX=x> ...] [<PATCH> ...]
+
+DESCRIPTION
+ This command creates a new kernel feature from the bare config
+ options and patches specified on the command-line. The new
+ feature will be created in recipe-space, specifically in either
+ the kernel .bbappend's /files/cfg or /files/features subdirectory,
+ depending on whether or not the feature contains config items only
+ or config items along with patches. The named feature must end
+ with .scc and must not contain a feature directory to contain the
+ feature (this will be determined automatically), and a feature
+ decription in double-quotes along with a capabilities string
+ (which for the time being can be one of: 'all' or 'board').
+"""
+
##
# yocto-layer help and usage strings
##