summaryrefslogtreecommitdiffstats
path: root/scripts/devtool
diff options
context:
space:
mode:
authorRandy Witt <randy.e.witt@linux.intel.com>2016-05-10 10:46:27 +1200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-11 10:33:43 +0100
commit832029356f64da093472f55ce0447a6052400985 (patch)
treef3bba42824d4b9a4293dfec1f76225f1f7377102 /scripts/devtool
parent32d80fe25823268a640590a2a9de766ff85d217c (diff)
downloadopenembedded-core-contrib-832029356f64da093472f55ce0447a6052400985.tar.gz
devtool: Fix build-sdk when pn doesn't match filename
If an image with the filename foo.bb could be built using the name "bar" instead, then build-sdk would fail to create the derivative sdk. This was because the code assumed that the file name matched the target, which is not necessarily the case. (From OE-Core rev: d58a326b6960be14b8a049253559aec9582b7d0d) Signed-off-by: Randy Witt <randy.e.witt@linux.intel.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts/devtool')
-rwxr-xr-xscripts/devtool5
1 files changed, 5 insertions, 0 deletions
diff --git a/scripts/devtool b/scripts/devtool
index 4780390654..9ac6e798d2 100755
--- a/scripts/devtool
+++ b/scripts/devtool
@@ -86,6 +86,11 @@ class ConfigHandler(object):
with open(self.config_file, 'w') as f:
self.config_obj.write(f)
+ def set(self, section, option, value):
+ if not self.config_obj.has_section(section):
+ self.config_obj.add_section(section)
+ self.config_obj.set(section, option, value)
+
class Context:
def __init__(self, **kwargs):
self.__dict__.update(kwargs)