aboutsummaryrefslogtreecommitdiffstats
path: root/openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
committerRichard Purdie <richard@openedhand.com>2006-05-26 13:28:14 +0000
commit1cd244533c2436e27a974d7c6a15262be7a49f50 (patch)
treec86f52fe49cfb4421a581f9cd7b9f65dfaea9a2e /openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch
parent39811ea4ae7f49ce27b6206727ffd929aed986dd (diff)
downloadopenembedded-core-contrib-1cd244533c2436e27a974d7c6a15262be7a49f50.tar.gz
Create openembedded-extras collection. Disabled by default - see local.conf.sample about how to enable
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@429 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch')
-rw-r--r--openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch b/openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..602aa8e021
--- /dev/null
+++ b/openembedded-extras/packages/python/python-2.4.3/fix-tkinter-detection.patch
@@ -0,0 +1,39 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- Python-2.4.1/setup.py~fix-tkinter-detection
++++ Python-2.4.1/setup.py
+@@ -999,7 +999,7 @@
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1018,22 +1018,6 @@
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)