aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-05-26 23:04:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-27 00:35:11 +0100
commit14fb3ff04c59e6a21bf39463073cffecd2e5b858 (patch)
tree9adeea988331d4c2222a28fff83de855bc8c5a19 /meta
parentb193e2fb163ad697ca136b240b682382f54f1d87 (diff)
downloadopenembedded-core-contrib-14fb3ff04c59e6a21bf39463073cffecd2e5b858.tar.gz
console-tools: use u-a also for fgconsole otherwise it collides with busybox
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/console-tools/console-tools_0.3.2.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-core/console-tools/console-tools_0.3.2.bb b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
index c7bee61591..c740119306 100644
--- a/meta/recipes-core/console-tools/console-tools_0.3.2.bb
+++ b/meta/recipes-core/console-tools/console-tools_0.3.2.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING.kbd;md5=9b2d91511d3d80d4d20ac6e6b0137fe9"
SUMMARY = "Allows you to set-up and manipulate the Linux console."
DESCRIPTION = "Provides tools that enable the set-up and manipulation of the linux console and console-font files."
-PR = "r2"
+PR = "r3"
SRC_URI = "${SOURCEFORGE_MIRROR}/lct/console-tools-${PV}.tar.gz \
file://codepage.patch;patch=1 \
@@ -37,17 +37,20 @@ do_install () {
mv ${D}${bindir}/chvt ${D}${bindir}/chvt.${PN}
mv ${D}${bindir}/deallocvt ${D}${bindir}/deallocvt.${PN}
mv ${D}${bindir}/openvt ${D}${bindir}/openvt.${PN}
+ mv ${D}${bindir}/fgconsole ${D}${bindir}/fgconsole.${PN}
}
pkg_postinst_${PN} () {
update-alternatives --install ${bindir}/chvt chvt chvt.${PN} 100
update-alternatives --install ${bindir}/deallocvt deallocvt deallocvt.${PN} 100
update-alternatives --install ${bindir}/openvt openvt openvt.${PN} 100
+ update-alternatives --install ${bindir}/fgconsole fgconsole fgconsole.${PN} 100
}
pkg_prerm_${PN} () {
update-alternatives --remove chvt chvt.${PN}
update-alternatives --remove deallocvt deallocvt.${PN}
update-alternatives --remove openvt openvt.${PN}
+ update-alternatives --remove fgconsole fgconsole.${PN}
}