summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-21 14:47:54 +0000
committerSteve Sakoman <steve@sakoman.com>2020-11-30 12:05:57 -1000
commit071806feb195961e59069f778c9ae8f27a739d9a (patch)
treede0d150bf1ba26224b358f354f1bda2a8c6a7fc3 /meta
parent20b8ffcbeadb6eb9e87356ee173ead43016d458b (diff)
downloadopenembedded-core-contrib-071806feb195961e59069f778c9ae8f27a739d9a.tar.gz
e2fsprogs: Fix a ptest permissions determinism issue
When comparing builds built with different host umasks, this file jumped out. The umask from do_compile was influencing ${D} and as cp was used to add the file it wasn't deterministic. Fix the file mode to ensure determinism. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 37f37f4a52de3711973b372160f23672b61ff6ad) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.4.bb b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.4.bb
index 4f7cafeac9..439928e433 100644
--- a/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.4.bb
+++ b/meta/recipes-devtools/e2fsprogs/e2fsprogs_1.45.4.bb
@@ -128,6 +128,8 @@ do_compile_ptest() {
}
do_install_ptest() {
+ # This file's permissions depends on the host umask so be deterministic
+ chmod 0644 ${B}/tests/test_data.tmp
cp -R --no-dereference --preserve=mode,links -v ${B}/tests ${D}${PTEST_PATH}/test
cp -R --no-dereference --preserve=mode,links -v ${S}/tests/* ${D}${PTEST_PATH}/test
sed -e 's!../e2fsck/e2fsck!e2fsck!g' \