summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-11-17 10:54:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-24 10:27:38 +0000
commit323b9728b31f785d64722ab3b03fae8d687f7cf4 (patch)
treed3f0b19adfb5ecb663b01b3e0d83c45f71a80306 /meta
parentc99bb79087e74a967286469e1d8888a546ebec83 (diff)
downloadopenembedded-core-contrib-323b9728b31f785d64722ab3b03fae8d687f7cf4.tar.gz
systemtap: avoid RDEPENDS on python3-core when not using python3
distutils3-base.bbclass unconditionally adds python3-core to RDEPENDS_${PN}, yuck. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 8dad5b15f0..923d64b975 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -25,7 +25,8 @@ PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
-inherit autotools gettext pkgconfig distutils3-base systemd
+inherit autotools gettext pkgconfig systemd
+inherit ${@bb.utils.contains('PACKAGECONFIG', 'python3-probes', 'distutils3-base', '', d)}
# exporter comes with python3-probes
PACKAGES =+ "${PN}-exporter"