aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-06-18 17:18:57 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-26 14:08:03 +0100
commit71158fa1a623125dae82c64c27e81dcdb2369e2d (patch)
tree60dd6746e06c59d0faf04b1efa07f0bdba6aa904 /meta
parent646adb4d90030970f6e2136f65b51b3c8b0c9d5c (diff)
downloadopenembedded-core-contrib-71158fa1a623125dae82c64c27e81dcdb2369e2d.tar.gz
piglit: fix floating dependence on freeglut
cmake can not handle "ifdef" and make floating dependence on freeglut_ext.h when make_depend, so remove to include freeglut_ext.h from header file if freegult is not in PACKAGECONFIG to fix this issue Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 9e6dc2c406..3a8b0acfa2 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -21,6 +21,12 @@ REQUIRED_DISTRO_FEATURES = "x11"
PACKAGECONFIG ??= ""
PACKAGECONFIG[freeglut] = "-DPIGLIT_USE_GLUT=1,-DPIGLIT_USE_GLUT=0,freeglut,"
+do_configure_prepend() {
+ if [ "${@bb.utils.contains('PACKAGECONFIG', 'freeglut', 'yes', 'no', d)}" = "no" ]; then
+ sed -i -e "/^#.*include <GL\/freeglut_ext.h>$/d" ${S}/src/piglit/glut_wrap.h
+ fi
+}
+
FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/"
RDEPENDS_${PN} = "waffle python python-mako python-json python-subprocess \