aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@tycoint.com>2016-11-10 10:46:19 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-23 11:02:27 +0000
commitb24a63d71b517af701dfedbc7f7b541d25af708f (patch)
treed3b536f7be4d80401043bc6e5eb7a5891b5bcd8d /meta
parent936eba3e1059d1dcd5e58c1ce76870fff7b11b3c (diff)
downloadopenembedded-core-contrib-b24a63d71b517af701dfedbc7f7b541d25af708f.tar.gz
opkg-utils: clear update-alternatives database on uninstall
When uninstalling update-alternatives, it doesn't seem to make much sense to keep the update-alternatives database around. In particular when removing packaging data, e.g. due to read-only rootfs, update-alternatives is removed from the target file system. Leaving its database around serves no purpose in that case as there is no way to use it afterwards anyway. This frees close to 700KB of (uncompressed) space in a busybox based environment. Signed-off-by: André Draszik <adraszik@tycoint.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index a7aec45f8d..19a852ec62 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -43,4 +43,9 @@ RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cw
RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
+pkg_postrm_update-alternatives-opkg() {
+ rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives
+ rmdir --ignore-fail-on-non-empty $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg
+}
+
BBCLASSEXTEND = "native nativesdk"