aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJoão Henrique Ferreira de Freitas <joaohf@gmail.com>2014-08-10 23:09:56 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 11:27:33 +0100
commitae10362c607bbe934d5c16507e543fb113c8edcb (patch)
tree772dfb3b2b25f54c421cfa6cfa4abb1ec2516468 /meta
parenta3d0a7bdc27036a957f477dfbe56244595c304d7 (diff)
downloadopenembedded-core-contrib-ae10362c607bbe934d5c16507e543fb113c8edcb.tar.gz
curl: add ssl to PACKAGECONFIG
This will allow curl run as nativesdk and fixes the following: fatal: unable to access 'https://...': Protocol https not supported or disabled in libcurl (From OE-Core rev: 76a702f4cde7ca8dd2946633f489386e43b6be26) Signed-off-by: João Henrique Ferreira de Freitas <joaohf@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/curl/curl_7.37.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/curl/curl_7.37.1.bb b/meta/recipes-support/curl/curl_7.37.1.bb
index 14bdff75db..dc1d6a618f 100644
--- a/meta/recipes-support/curl/curl_7.37.1.bb
+++ b/meta/recipes-support/curl/curl_7.37.1.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e66
DEPENDS = "zlib gnutls"
DEPENDS_class-native = "zlib-native openssl-native"
-DEPENDS_class-nativesdk = "nativesdk-zlib"
+DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-openssl"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://pkgconfig_fix.patch \
@@ -25,7 +25,7 @@ inherit autotools pkgconfig binconfig multilib_header
PACKAGECONFIG ??= "gnutls ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
PACKAGECONFIG_class-native = "ipv6 ssl"
-PACKAGECONFIG_class-nativesdk = "ipv6"
+PACKAGECONFIG_class-nativesdk = "ipv6 ssl"
PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
PACKAGECONFIG[ssl] = "--with-ssl, --without-ssl, ,"
PACKAGECONFIG[gnutls] = "--with-gnutls=${STAGING_LIBDIR}/../, --without-gnutls, gnutls,"