aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-06 20:05:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:06 +0100
commit866070c78a396f8d394155cfb8845d84aab198f0 (patch)
tree437a754835ba35a47dba88f66e451e86a933edb2 /meta
parent020f816da4ddfb9d1052a6156e44b20213981927 (diff)
downloadopenembedded-core-contrib-866070c78a396f8d394155cfb8845d84aab198f0.tar.gz
logrotate: fix recompile error
Fixed: NOTE: make -j 32 make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `logrotate.o'. Stop. This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't regenerated when recompile, the content of the .depend are: [snip] logrotate.o: /path/to/sysroot/4.9.0/include/stddef.h [snip] And Makefile includes the .depend file if it exists, so there would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist. Remove .depend will fix the problem. (From OE-Core rev: 31de4a9d9ecc532ff6a6f5641852dc412a337cd7) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.8.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
index b386b85bf6..3a6a2287db 100644
--- a/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.7.bb
@@ -18,6 +18,11 @@ SRC_URI[sha256sum] = "f6ba691f40e30e640efa2752c1f9499a3f9738257660994de70a45fe00
EXTRA_OEMAKE = ""
+do_compile_prepend() {
+ # Make sure the recompile is OK
+ rm -f ${B}/.depend
+}
+
do_install(){
oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir}
mkdir -p ${D}${sysconfdir}/logrotate.d