aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-06 20:05:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:06 +0100
commit8371105be5af4ba88b6b4c862eb7cad852922cf1 (patch)
treecd48d8671cc077cf00ec5a69724bac03b8c20a37 /meta
parentdfc203c54b90e5eab5fd6f827a1b717eeb6aa1a5 (diff)
downloadopenembedded-core-contrib-8371105be5af4ba88b6b4c862eb7cad852922cf1.tar.gz
u-boot-mkimage: fix recompile error
Fixed: make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `crc32.o'. Stop. make: *** Waiting for unfinished jobs.... ERROR: oe_runmake failed This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't regenerated when recompile, the content of it are: [snip] crc32.o: /path/to/sysroot/4.9.0/include/stddef.h [snip] And Makefile includes the .depend file if it exists, so there would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist. Remove .*.d (a few .d files, its Makefile uses this wildcard) will fix the problem. (From OE-Core rev: b31dd7d1fbdd9165872a31c11c6627549609fcb3) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
index 2ca6050bf9..93c8102e73 100644
--- a/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
+++ b/meta/recipes-bsp/u-boot/u-boot-mkimage_2013.07.bb
@@ -17,6 +17,9 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTLDFLAGS="${LDFLAGS}" HOSTSTRIP=true'
do_compile () {
+ # Make sure the recompile is OK
+ rm -f ${B}/tools/.depend
+
oe_runmake tools
}