aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2014-08-11 09:15:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 17:43:44 +0100
commit4e3e0df0eb62f73859a7edfbc18e641cbbec036b (patch)
tree9b106383fe6fd8a7cc1b81452b193fc81baa7fd4 /meta
parentfe5b333e1a82174287bea0ef6a6620bf9eb69e46 (diff)
downloadopenembedded-core-contrib-4e3e0df0eb62f73859a7edfbc18e641cbbec036b.tar.gz
python-dbus: use PACKAGECONFIG for doc generation
Adds 'docs' (for html doc generation) and 'api-docs' (for API doc generation) configurations and leaves them both disabled by default. This avoids autodetected dependency upon docutils. Fixes [YOCTO #6530] (From OE-Core rev: 7216ddad59f6a2315323befa69eebdbf07625e25) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-dbus_1.2.0.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-dbus_1.2.0.bb b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
index e64f99f87a..b314dce1c7 100644
--- a/meta/recipes-devtools/python/python-dbus_1.2.0.bb
+++ b/meta/recipes-devtools/python/python-dbus_1.2.0.bb
@@ -14,6 +14,10 @@ S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools pkgconfig
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
+PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
+
export BUILD_SYS
export HOST_SYS