aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-08-06 20:05:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:06 +0100
commit020f816da4ddfb9d1052a6156e44b20213981927 (patch)
treefb58863ef955842823a3f452947ba4e407b49316 /meta
parent3f0bbf6659e5fb3bb72981ea0052997e421a213e (diff)
downloadopenembedded-core-contrib-020f816da4ddfb9d1052a6156e44b20213981927.tar.gz
libnewt: fix recompile error
Fixed: NOTE: make -j 32 make: *** No rule to make target `/path/to/sysroot/4.9.0/include/stddef.h', needed by `test.o'. Stop. This happens when upgrade gcc from 4.9.0 to 4.9.1, and the .depend isn't regenerated when recompile, the content of the .depend are: [snip] test.o: /path/to/sysroot/4.9.0/include/stddef.h [snip] And Makefile includes the .depend file if it exists, so there would be errors when /path/to/sysroot/4.9.0/include/stddef.h doesn't exist. Remove .depend will fix the problem. (From OE-Core rev: bf2f8abff4eb55cd960065eaba032c96068acf08) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.17.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.17.bb b/meta/recipes-extended/newt/libnewt_0.52.17.bb
index 09b017e24e..28d5cf1a34 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.17.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.17.bb
@@ -46,4 +46,9 @@ do_configure_prepend() {
sh autogen.sh
}
+do_compile_prepend() {
+ # Make sure the recompile is OK
+ rm -f ${B}/.depend
+}
+
FILES_whiptail = "${bindir}/whiptail"