summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2022-05-17 07:34:07 -1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-20 19:08:20 +0100
commit4b1f0f7542abcb8606688c974695a6c8a142e7a2 (patch)
tree709d0c8de75138067f323cd9afa094c1bbd94693 /meta
parentdf4e37ef888ad11f98c2f17ab4bc48dbd5417790 (diff)
downloadopenembedded-core-contrib-4b1f0f7542abcb8606688c974695a6c8a142e7a2.tar.gz
python3: fix reproducibility issue with python3-core
traceback.cpython-310.pyc is non-deterministic due to 'frozenset' being written without strict ordering. For now let's just not install the problematic file. Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3_3.10.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3_3.10.4.bb b/meta/recipes-devtools/python/python3_3.10.4.bb
index d678d55083..2ef320350e 100644
--- a/meta/recipes-devtools/python/python3_3.10.4.bb
+++ b/meta/recipes-devtools/python/python3_3.10.4.bb
@@ -193,6 +193,11 @@ do_install:append() {
rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
+ # Similar to the above, we're getting reproducibility issues with
+ # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
+ # so remove it too
+ rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
+
# Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
# style targets as they're only used when python is called with the -O or -OO options
# which is rare.