aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-19 10:25:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-20 13:40:16 +0000
commit547174fc834273af67a2f7e50a3cf6c8e3b900f4 (patch)
tree44e736f773cb4eb1091b9dc6092362eb833fe570 /meta
parent14c291e1fb6324da46885b69fbd7f01b3c6b053e (diff)
downloadopenembedded-core-contrib-547174fc834273af67a2f7e50a3cf6c8e3b900f4.tar.gz
gcc-runtime: Drop building libmpx
libmpx is not supported any longer and infact has been removed completely from gcc-9, see https://github.com/gcc-mirror/gcc/commit/1e42d5c637e1b1f65dfddd0923dfb25676bb56e5 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime.inc29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-runtime.inc b/meta/recipes-devtools/gcc/gcc-runtime.inc
index 95153da20c..50ecc815a5 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-runtime.inc
@@ -29,9 +29,6 @@ RUNTIMELIBSSP_mingw32 ?= "libssp"
RUNTIMETARGET = "${RUNTIMELIBSSP} libstdc++-v3 libgomp libatomic ${RUNTIMELIBITM} \
${@bb.utils.contains_any('FORTRAN', [',fortran',',f77'], 'libquadmath', '', d)} \
"
-RUNTIMETARGET_append_x86 = " libmpx"
-RUNTIMETARGET_append_x86-64 = " libmpx"
-RUNTIMETARGET_remove_libc-musl = "libmpx"
# libiberty
# libmudflap
@@ -160,18 +157,6 @@ PACKAGES = "\
libitm-dev \
libitm-staticdev \
"
-PACKAGES_append_x86 = "\
- libmpx \
- libmpx-dev \
- libmpx-staticdev \
-"
-
-PACKAGES_append_x86-64 = "\
- libmpx \
- libmpx-dev \
- libmpx-staticdev \
-"
-
# The base package doesn't exist, so we clear the recommends.
RRECOMMENDS_${PN}-dbg = ""
@@ -274,17 +259,3 @@ FILES_libitm-dev = "\
SUMMARY_libitm-dev = "GNU transactional memory support library - development files"
FILES_libitm-staticdev = "${libdir}/libitm.a"
SUMMARY_libitm-staticdev = "GNU transactional memory support library - static development files"
-
-
-FILES_libmpx = "${libdir}/libmpx.so.* ${libdir}/libmpxwrappers.so.*"
-SUMMARY_libmpx = "Intel Memory Protection Extension library"
-FILES_libmpx-dev = "\
- ${libdir}/libmpxwrappers.so \
- ${libdir}/libmpxwrappers.la \
- ${libdir}/libmpx.so \
- ${libdir}/libmpx.la \
- ${libdir}/libmpx.spec \
-"
-SUMMARY_libmpx-dev = "Intel Memory Protection Extension library - development files"
-FILES_libmpx-staticdev = "${libdir}/libmpx.a ${libdir}/libmpxwrappers.a"
-SUMMARY_libmpx-staticdev = "Intel Memory Protection Extension library - static development files"