aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2015-09-18 08:43:42 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-21 15:20:10 +0100
commit6c133405c790d29859d441cc596e6459cb32537f (patch)
tree21468daf14df3a36cadba694f19e51d272d3a534 /meta
parentda9ddf48ed4a13cdc47649e22ab6ef7e36e01fdf (diff)
downloadopenembedded-core-contrib-6c133405c790d29859d441cc596e6459cb32537f.tar.gz
libpcre: Allow building 16 and 32bit libpcre versions
This change allows selecting the 8, 16 or 32 bit version via PACKAGECONFIG. By default only the 8bit version is built, this corresponds to the old behavior. Some packages like Qt5 require the 16 bit version of libpcre. After this change the corresponding layer can easily enable the version needed via .bbappend. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/libpcre/libpcre_8.37.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre_8.37.bb b/meta/recipes-support/libpcre/libpcre_8.37.bb
index bcfc9e9afa..1880639a27 100644
--- a/meta/recipes-support/libpcre/libpcre_8.37.bb
+++ b/meta/recipes-support/libpcre/libpcre_8.37.bb
@@ -22,6 +22,11 @@ S = "${WORKDIR}/pcre-${PV}"
PROVIDES += "pcre"
DEPENDS += "bzip2 zlib"
+PACKAGECONFIG ??= "pcre8"
+
+PACKAGECONFIG[pcre8] = "--enable-pcre8,--disable-pcre8"
+PACKAGECONFIG[pcre16] = "--enable-pcre16,--disable-pcre16"
+PACKAGECONFIG[pcre32] = "--enable-pcre32,--disable-pcre32"
PACKAGECONFIG[pcretest-readline] = "--enable-pcretest-libreadline,--disable-pcretest-libreadline,readline,"
BINCONFIG = "${bindir}/pcre-config"