aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorZhenhua Luo <b19537@freescale.com>2012-11-30 08:31:57 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-03 14:45:09 +0000
commitff5552a8432298c32aec2ace72656b0d7059dad3 (patch)
tree94e8f6d04ee8433a7e176082f4b78aa8cca71cd8 /meta
parent644deda668950702c0c35da9fef0a2844db7a9d9 (diff)
downloadopenembedded-core-contrib-ff5552a8432298c32aec2ace72656b0d7059dad3.tar.gz
libxml2: add --with-fexceptions in configure flags to support exception handling in C++ programs
Without this flag, the library has a problem with C++ programs using exception handling. Signed-off-by: Zhenhua Luo <b19537@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/libxml/libxml2.inc4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/libxml/libxml2.inc b/meta/recipes-core/libxml/libxml2.inc
index 9ec507bad9..615c89e856 100644
--- a/meta/recipes-core/libxml/libxml2.inc
+++ b/meta/recipes-core/libxml/libxml2.inc
@@ -9,6 +9,8 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=bb90c48926316d9af6e2d70ca7013ade \
file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
+INC_PR = "r1"
+
DEPENDS_class-native = "python-native"
DEPENDS =+ "zlib"
@@ -24,7 +26,7 @@ do_configure_prepend () {
sed -i -e '/.*ansidecl.h.*/d' ${S}/configure.in
}
-EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-lzma"
+EXTRA_OECONF = "--without-python --without-debug --without-legacy --without-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
EXTRA_OECONF_class-native = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
EXTRA_OECONF_class-nativesdk = "--with-python=${STAGING_BINDIR}/python --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma"
EXTRA_OECONF_linuxstdbase = "--without-python --with-debug --with-legacy --with-catalog --with-docbook --with-c14n --without-lzma"