aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-29 15:16:17 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-30 11:03:24 +0000
commitfbec192f6bc41a335ede85843ba22a89d13501ab (patch)
treef301ffb623a0904351465c6261ee3ee4a6b5f598 /meta
parent6e4a1743a88fe6a002ca8f784b2dad3f493984b5 (diff)
downloadopenembedded-core-contrib-fbec192f6bc41a335ede85843ba22a89d13501ab.tar.gz
udev: Ensure tmpfs are mounted and volatile/run exists
There is a race with udev where eiher the run directory can get replaced during bootup leading to ude errors, or if the tmpfs was mounted and populate-volatiles hasn't run, udev won't start at all. This ensures that any tmpfs get mounted before udev starts and that the default volatiles/run directory at least exists, fixing the races and boot time errors caused after the recent udev upgrade. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/udev/udev/init5
-rw-r--r--meta/recipes-core/udev/udev_182.bb2
2 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-core/udev/udev/init b/meta/recipes-core/udev/udev/init
index ca02abb6f1..74449feaaa 100644
--- a/meta/recipes-core/udev/udev/init
+++ b/meta/recipes-core/udev/udev/init
@@ -37,9 +37,8 @@ export ACTION=add
echo "Starting udev"
# mount the tmpfs on /dev, if not already done
-LANG=C awk '$2 == "/dev" && ($3 == "tmpfs" || $3 == "devtmpfs") { exit 1 }' /proc/mounts && {
- mount -n -o mode=0755 -t tmpfs none "/dev"
-}
+mount -a -t tmpfs
+mkdir -p /var/volatile/run
[ -e /dev/pts ] || mkdir -m 0755 /dev/pts
[ -e /dev/shm ] || mkdir -m 1777 /dev/shm
diff --git a/meta/recipes-core/udev/udev_182.bb b/meta/recipes-core/udev/udev_182.bb
index 8e4a391286..c41de9fef4 100644
--- a/meta/recipes-core/udev/udev_182.bb
+++ b/meta/recipes-core/udev/udev_182.bb
@@ -1,6 +1,6 @@
include udev.inc
-PR = "r1"
+PR = "r2"
# module-init-tools from kmod_git will provide libkmod runtime
DEPENDS += "module-init-tools"