aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-07-20 14:12:09 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:43 +0100
commitf2dc23cf886de95040080c4398a3320c211b65fa (patch)
tree8678c5bfe9519e0d9636c1acadf6f3422d54fdba /meta
parent9090abb6240d8a3bf2ff0acd84e13c363440896b (diff)
downloadopenembedded-core-contrib-f2dc23cf886de95040080c4398a3320c211b65fa.tar.gz
bash: fix warning about bashbug reference /usr/bin when installed in /bin
Change the installation process so we have bashbug in ${bindir} and bash at ${base_bindir}. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/bash/bash.inc11
-rw-r--r--meta/recipes-extended/bash/bash_4.2.bb2
2 files changed, 9 insertions, 4 deletions
diff --git a/meta/recipes-extended/bash/bash.inc b/meta/recipes-extended/bash/bash.inc
index ff9b0ce999..3684191d03 100644
--- a/meta/recipes-extended/bash/bash.inc
+++ b/meta/recipes-extended/bash/bash.inc
@@ -11,9 +11,6 @@ inherit autotools gettext update-alternatives
PARALLEL_MAKE = ""
-bindir = "/bin"
-sbindir = "/sbin"
-
EXTRA_OECONF = "--enable-job-control"
export CC_FOR_BUILD = "${BUILD_CC}"
@@ -30,6 +27,14 @@ do_configure_prepend () {
fi
}
+do_install_append () {
+ # Move /usr/bin/bash to /bin/bash, if need
+ if [ "${base_bindir}" != "${bindir}" ]; then
+ mkdir -p ${D}${base_bindir}
+ mv ${D}${bindir}/bash ${D}${base_bindir}
+ fi
+}
+
pkg_postinst_${PN} () {
touch $D${sysconfdir}/shells
grep -q "bin/bash" $D${sysconfdir}/shells || echo /bin/bash >> $D${sysconfdir}/shells
diff --git a/meta/recipes-extended/bash/bash_4.2.bb b/meta/recipes-extended/bash/bash_4.2.bb
index e96709a59c..50f2ff64b8 100644
--- a/meta/recipes-extended/bash/bash_4.2.bb
+++ b/meta/recipes-extended/bash/bash_4.2.bb
@@ -1,6 +1,6 @@
require bash.inc
-PR = "r2"
+PR = "r4"
SRC_URI = "${GNU_MIRROR}/bash/${BPN}-${PV}.tar.gz;name=tarball \
${GNU_MIRROR}/bash/bash-4.2-patches/bash42-001;apply=yes;striplevel=0;name=patch001 \