aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-03-18 14:29:59 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-23 17:10:21 +0000
commite0eeb10144db74c0671acd684059e8a6f82a572f (patch)
treebd364127b89988d2bda73cfe80255e0f51a97a11 /meta
parentba89ba8e02185c7adb92240f119a57e7b21adfa7 (diff)
downloadopenembedded-core-contrib-e0eeb10144db74c0671acd684059e8a6f82a572f.tar.gz
gcc-runtime_4.5.1.bb: Fix ICE in gcc-runtime with -feliminate-dwarf2-dups
GCC 4.5 ends up in an ICE when compiling libstdc++ pre compiled header so we eliminate -feliminate-dwarf2-dups for gcc-runtime Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
index 9eb658b12c..9d4e158fb5 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
@@ -1,4 +1,4 @@
-PR = "r4"
+PR = "r5"
require gcc-${PV}.inc
require gcc-configure-runtime.inc
@@ -9,3 +9,8 @@ SRC_URI_append = "file://fortran-cross-compile-hack.patch"
ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_INCDIR}"
EXTRA_OECONF += "--disable-libunwind-exceptions"
+
+# gcc 4.5 ends up in ICE when using -feliminate-dwarf2-dups in libstdc++
+# compiling pre compiled headers so we remove this option when compiling
+# to workaround it
+CXXFLAGS := "${@oe_filter_out('-feliminate-dwarf2-dups', '${CXXFLAGS}', d)}"