aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2012-03-30 13:59:18 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-04 16:54:47 +0100
commitb56e3680e729d8216fe533cdfaf4678fe94b76f0 (patch)
tree8e7a889e3680255b947b850826a4549965133375 /meta
parente65b6a4282d5c4882d0565b79ccba99db90161ff (diff)
downloadopenembedded-core-contrib-b56e3680e729d8216fe533cdfaf4678fe94b76f0.tar.gz
eglibc packaging: locale packaging configuration
The PACKAGE_NO_GCONV var manipulations ware happening in the eglibc-options.inc file, and the eglibc-locale recipe do not see it. Moving that into the libc-package.bbclass which is common to eglibc & eglibc-locale recipes. This fixes bug: [YOCTO #2089] This avoids this error for poky-tiny NOTE: package eglibc-locale-2.13-r19: task do_populate_sysroot: Started ERROR: Error executing a python function in /opt/poky.git/meta/recipes-core/eglibc/eglibc-locale_2.13.bb: OSError: [Errno 2] No such file or directory: '/home/rchatre/concordia/dev/ccd-distro-work/tmp/work/core2-poky-linux/eglibc-locale-2.13-r19/package/usr/lib/gconv' ERROR: The stack trace of python calls that resulted in this exception/failure was: ERROR: File "package_do_split_gconvs", line 264, in <module> ERROR:· ERROR: File "package_do_split_gconvs", line 45, in package_do_split_gconvs ERROR:· ERROR: File "package.bbclass", line 30, in do_split_packages ERROR:· ERROR: The code that was being executed was: ERROR: 0260:»------»-------bb.note("generation of binary locales disabled. this may break i18n!") ERROR: 0261: ERROR: 0262: ERROR: 0263: ERROR: *** 0264:package_do_split_gconvs(d) ERROR: 0265: ERROR: (file: 'package_do_split_gconvs', lineno: 264, function: <module>) ERROR: 0041:»------»-------»-------d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc')) ERROR: 0042: ERROR: 0043:»------do_split_packages(d, gconv_libdir, file_regex='^(.*)\.so$', output_pattern=bpn+'-gconv-%s', \ ERROR: 0044:»------»-------description='gconv module for character set %s', hook=calc_gconv_deps, \ ERROR: *** 0045:»------»-------extra_depends=bpn+'-gconv') ERROR: 0046: ERROR: 0047:»------def calc_charmap_deps(fn, pkg, file_regex, output_pattern, group): ERROR: 0048:»------»-------deps = [] ERROR: 0049:»------»-------f = open(fn, "r") ERROR: (file: 'package_do_split_gconvs', lineno: 45, function: package_do_split_gconvs) ERROR: Function failed: package_do_split_gconvs ERROR: Logfile of failure stored in: /home/rchatre/concordia/dev/ccd-distro-work/tmp/work/core2-poky-linux/eglibc-locale-2.13-r19/temp/log.do_package.31042 NOTE: package eglibc-locale-2.13-r19: task do_package: Failed ERROR: Task 552 (/opt/poky.git/meta/recipes-core/eglibc/eglibc-locale_2.13.bb, do_package) failed with exit code '1' Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/libc-package.bbclass8
-rw-r--r--meta/recipes-core/eglibc/eglibc-options.inc6
2 files changed, 8 insertions, 6 deletions
diff --git a/meta/classes/libc-package.bbclass b/meta/classes/libc-package.bbclass
index 957243d1d8..7cde7701ae 100644
--- a/meta/classes/libc-package.bbclass
+++ b/meta/classes/libc-package.bbclass
@@ -35,6 +35,14 @@ python __anonymous () {
d.setVar("DEPENDS", depends)
d.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "compile")
break
+
+ distro_features = (d.getVar('DISTRO_FEATURES', True) or '').split()
+
+ # try to fix disable charsets/locales/locale-code compile fail
+ if 'libc-charsets' in distro_features and 'libc-locales' in distro_features and 'libc-locale-code' in distro_features:
+ d.setVar('PACKAGE_NO_GCONV', '0')
+ else:
+ d.setVar('PACKAGE_NO_GCONV', '1')
}
OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
diff --git a/meta/recipes-core/eglibc/eglibc-options.inc b/meta/recipes-core/eglibc/eglibc-options.inc
index baf4f4b06c..bd90ee79a2 100644
--- a/meta/recipes-core/eglibc/eglibc-options.inc
+++ b/meta/recipes-core/eglibc/eglibc-options.inc
@@ -126,10 +126,4 @@ def features_to_eglibc_settings(d):
eglibc_cfg('libc-posix-regexp-glibc', distro_features, 'OPTION_POSIX_REGEXP_GLIBC', cnf)
eglibc_cfg('libc-posix-wchar-io', distro_features, 'OPTION_POSIX_WIDE_CHAR_DEVICE_IO', cnf)
- # try to fix disable charsets/locales/locale-code compile fail
- if 'libc-charsets' in distro_features and 'libc-locales' in distro_features and 'libc-locale-code' in distro_features:
- d.setVar('PACKAGE_NO_GCONV', '0')
- else:
- d.setVar('PACKAGE_NO_GCONV', '1')
-
return "\n".join(cnf)