aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-04-26 11:45:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-29 14:43:53 +0100
commitae38cac225f0d84e6acecb6bc46df939d37cd031 (patch)
tree68701c0dd665ffe93387d82a8184bb678f38039f /meta
parent44eae13c164ca6e15a6013eafeab3eb44f24c8e0 (diff)
downloadopenembedded-core-contrib-ae38cac225f0d84e6acecb6bc46df939d37cd031.tar.gz
matchbox-panel-2: bump srcrev to fix compile warnings
The older versions of matchbox-panel were naively using -Werror which causes warnings with gcc 4.6 (which were patched away) and again more with gcc 4.8. I'd already fixed this upstream so bump the srvrev and drop the patch. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/gcc-4.6.0-compile.patch53
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb7
2 files changed, 3 insertions, 57 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/gcc-4.6.0-compile.patch b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/gcc-4.6.0-compile.patch
deleted file mode 100644
index 71a4727391..0000000000
--- a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/gcc-4.6.0-compile.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-Upstream-Status: Inappropriate [other] - need clean up
-
-diff -ur git.ORIG/applets/startup/startup.c git/applets/startup/startup.c
---- git.ORIG/applets/startup/startup.c 2011-04-28 08:13:25.000000000 -0600
-+++ git/applets/startup/startup.c 2011-04-28 09:36:48.521990746 -0600
-@@ -210,9 +210,8 @@
- {
- XEvent *xevent;
- xevent = (XEvent *) gdk_xevent;
-- gboolean ret;
-
-- ret = sn_display_process_event (applet->sn_display, xevent);
-+ sn_display_process_event (applet->sn_display, xevent);
-
- return GDK_FILTER_CONTINUE;
- }
-@@ -223,7 +222,6 @@
- {
- StartupApplet *applet;
- Display *xdisplay;
-- SnMonitorContext *context;
-
- /* Create applet data structure */
- applet = g_slice_new0 (StartupApplet);
-@@ -248,7 +246,7 @@
-
- applet->sn_display = sn_display_new (xdisplay, NULL, NULL);
-
-- context = sn_monitor_context_new (applet->sn_display,
-+ sn_monitor_context_new (applet->sn_display,
- DefaultScreen(xdisplay),
- monitor_event_func,
- (void *) applet,
-diff -ur git.ORIG/applets/startup-notify/startup.c git/applets/startup-notify/startup.c
---- git.ORIG/applets/startup-notify/startup.c 2011-04-28 08:05:46.000000000 -0600
-+++ git/applets/startup-notify/startup.c 2011-04-28 09:42:17.793864786 -0600
-@@ -305,7 +305,6 @@
- StartupApplet *applet;
- GtkWidget *widget;
- Display *xdisplay;
-- SnMonitorContext *context;
-
- applet = g_slice_new0 (StartupApplet);
-
-@@ -317,7 +316,7 @@
-
- applet->sn_display = sn_display_new (xdisplay, NULL, NULL);
-
-- context = sn_monitor_context_new (applet->sn_display,
-+ sn_monitor_context_new (applet->sn_display,
- DefaultScreen (xdisplay),
- monitor_event_func,
- applet, NULL);
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
index dbe1fadf51..1160b87f47 100644
--- a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_git.bb
@@ -7,11 +7,11 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://matchbox-panel/mb-panel.h;endline=10;md5=0b7db28f4b6863fb853d0467e590019a \
file://applets/startup/startup.c;endline=22;md5=b0a64fbef3097d79f8264e6907a98f03"
-DEPENDS = "gtk+ startup-notification dbus dbus-glib"
+DEPENDS = "gnome-common gtk+ startup-notification dbus dbus-glib"
DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
-SRCREV = "cdf7a22716b87468f10573f622d5c7a58a684e35"
+SRCREV = "c03234512784b78a95b5aa9ca445d05836b9d51a"
PV = "2.0+git${SRCPV}"
PR = "r0"
@@ -19,8 +19,7 @@ RPROVIDES_${PN} = "matchbox-panel"
RREPLACES_${PN} = "matchbox-panel"
RCONFLICTS_${PN} = "matchbox-panel"
-SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git \
- file://gcc-4.6.0-compile.patch"
+SRC_URI = "git://git.yoctoproject.org/${BPN};protocol=git"
EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"