aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-10-08 15:20:42 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-08 15:20:42 +0100
commitad042da70348e9f301a25b855248e8fbce495ab8 (patch)
treeab2d84d9cdebb8621b1a3c53f84127be0b4f60a0 /meta
parent93c19abbc2e4de18a15315d9a6e0635331507fc0 (diff)
downloadopenembedded-core-contrib-ad042da70348e9f301a25b855248e8fbce495ab8.tar.gz
meta-toolchain: Fix libGL.so not found issues
Fix libGL.so not found issues by making sure ld.so.cache from the host system is used to locate libraries. Also, fix a /usr/ reference that should be /var to keep the installation tarball clean. [BUGID #228] Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-tbd/meta/meta-toolchain.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-tbd/meta/meta-toolchain.bb b/meta/recipes-tbd/meta/meta-toolchain.bb
index 8054b5f7b8..f976457bc5 100644
--- a/meta/recipes-tbd/meta/meta-toolchain.bb
+++ b/meta/recipes-tbd/meta/meta-toolchain.bb
@@ -47,7 +47,7 @@ do_populate_sdk() {
install -d ${SDK_OUTPUT}/${SDKPATHNATIVE}${localstatedir_nativesdk}/lib/opkg
mv ${SDK_OUTPUT}/var/lib/opkg/* ${SDK_OUTPUT}/${SDKPATHNATIVE}${localstatedir_nativesdk}/lib/opkg/
- rm -Rf ${SDK_OUTPUT}/usr
+ rm -Rf ${SDK_OUTPUT}/var
# Don't ship any libGL in the SDK
rm -rf ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/libGL*
@@ -72,6 +72,9 @@ do_populate_sdk() {
#rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
+ # Link the ld.so.cache file into the hosts filesystem
+ ln -s /etc/ld.so.cache ${SDKPATHNATIVE}/etc/ld.so.cache
+
# Setup site file for external use
siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}
touch $siteconfig