aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-01-21 12:15:30 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 12:43:38 +0000
commita2553b5f8b80ca0cd578afa2d2857ebb2b70ee3c (patch)
treefd8d5a3b3964f3f4540e7dc2654f89941ec41531 /meta
parent272661a7fca7e0ee8f6b0d7a4ba97f09a82a540e (diff)
downloadopenembedded-core-contrib-a2553b5f8b80ca0cd578afa2d2857ebb2b70ee3c.tar.gz
systemd: skip in non-systemd distros to fix world builds
Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/systemd/systemd_196.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_196.bb b/meta/recipes-core/systemd/systemd_196.bb
index 1861437236..85bb4f9884 100644
--- a/meta/recipes-core/systemd/systemd_196.bb
+++ b/meta/recipes-core/systemd/systemd_196.bb
@@ -247,3 +247,11 @@ update-alternatives --remove reboot ${base_bindir}/systemctl
update-alternatives --remove shutdown ${base_bindir}/systemctl
update-alternatives --remove poweroff ${base_bindir}/systemctl
}
+
+
+# As this recipe builds udev, respect the systemd DISTRO_FEATURE so we don't try
+# building udev and systemd in world builds.
+python () {
+ if not oe.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
+ raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
+}