aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-10-10 08:55:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-10 17:54:57 +0100
commit9d002f7cdc5309c4d850a76e4fd73ff04c980a07 (patch)
tree22a60e00c84d6236b739a4e7263a31130145be91 /meta
parentcbcfdeb1d55e2e76f199750bda401bad126ae234 (diff)
downloadopenembedded-core-contrib-9d002f7cdc5309c4d850a76e4fd73ff04c980a07.tar.gz
eglibc: force make to use /bin/bash
The eglibc core build still has a number of issues with /bin/dash. Recently found is both sysdeps/unix/make-syscalls.sh and it's output, which make calls via SHELL do not play well with /bin/dash. By force make to use /bin/bash via SHELL setting it works correctly. Currenly known issues are: make-syscalls.sh line with a bad substitution, which can be corrected by: vdso_symver="$(printf '%s\n' ${vdso_symver} | sed 's/\./_/')" Following that there is an issue with emiting a '\n' through a second echo and then to the compiler. There maybe more issues beyond that. [YOCTO #3080] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/eglibc.inc5
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-core/eglibc/eglibc.inc b/meta/recipes-core/eglibc/eglibc.inc
index cae955d523..e1ec6b2b8c 100644
--- a/meta/recipes-core/eglibc/eglibc.inc
+++ b/meta/recipes-core/eglibc/eglibc.inc
@@ -51,6 +51,11 @@ EXTRA_OEMAKE[vardepsexclude] += "EGLIBCPARALLELISM"
EXTRA_OEMAKE += "${EGLIBCPARALLELISM}"
PARALLEL_MAKE = ""
+# eglibc make-syscalls.sh has a number of issues with /bin/dash and
+# it's output which make calls via the SHELL also has issues, so
+# ensure make uses /bin/bash
+EXTRA_OEMAKE += "SHELL=/bin/bash"
+
OE_FEATURES = "${@features_to_eglibc_settings(d)}"
do_configure_prepend() {
sed -e "s#@BASH@#/bin/sh#" -i ${S}/elf/ldd.bash.in
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 32b03645e5..78bf9bedaf 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -3,7 +3,7 @@ require eglibc.inc
SRCREV = "20393"
DEPENDS += "gperf-native kconfig-frontends-native"
-PR = "r14"
+PR = "r15"
PR_append = "+svnr${SRCPV}"
EGLIBC_BRANCH="eglibc-2_16"