aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-07-24 09:23:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:39:49 +0100
commit9921cb0104ea36daf909c110bb6767e5fd307da0 (patch)
tree3a249f1851c07cce24bf04ef1c8965f130b0315a /meta
parent45b8dcc65b46c68151093a2931cce675abb92813 (diff)
downloadopenembedded-core-contrib-9921cb0104ea36daf909c110bb6767e5fd307da0.tar.gz
busybox:udhcpc: fix the root_is_nfs() function
[YOCTO #2788] The system will be hung when udhcpc starts, if nfs is mounted at "/" directory and default route is different after starting udhcpc. The cause is that root_is_nfs() does not work after kernel-2.6.37, since the device name has been changed from /dev/root to ${IPADDR}:${NFSDIR} on /proc/mounts. which leads to remove the default routes to nfs server, Now we use a loose match to check if rootfs is nfs. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/busybox/busybox_1.19.4.bb2
-rw-r--r--meta/recipes-core/busybox/files/simple.script3
2 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.19.4.bb b/meta/recipes-core/busybox/busybox_1.19.4.bb
index cc97e2a853..7bdfbda538 100644
--- a/meta/recipes-core/busybox/busybox_1.19.4.bb
+++ b/meta/recipes-core/busybox/busybox_1.19.4.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r10"
+PR = "r11"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://B921600.patch \
diff --git a/meta/recipes-core/busybox/files/simple.script b/meta/recipes-core/busybox/files/simple.script
index 27368f0ee5..69739850d8 100644
--- a/meta/recipes-core/busybox/files/simple.script
+++ b/meta/recipes-core/busybox/files/simple.script
@@ -10,7 +10,8 @@ RESOLV_CONF="/etc/resolv.conf"
# return 0 if root is mounted on a network filesystem
root_is_nfs() {
- grep -qe '^/dev/root.*\(nfs\|smbfs\|ncp\|coda\) .*' /proc/mounts
+ sed -n 's/^[^ ]* \([^ ]*\) \([^ ]*\) .*$/\1 \2/p' /proc/mounts |
+ grep -q "^/ \(nfs\|smbfs\|ncp\|coda\)$"
}
have_bin_ip=0