aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorXiaofeng Yan <xiaofeng.yan@windriver.com>2012-03-26 18:27:40 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-04 17:01:30 +0100
commit8f25bf3881ee568bbe03132d2205da5382fa7dd6 (patch)
tree53873b85195da891033b439bcea7a5196d237b3e /meta
parentbbc7f24d463c11b16f000462528c18bbb86b1e88 (diff)
downloadopenembedded-core-contrib-8f25bf3881ee568bbe03132d2205da5382fa7dd6.tar.gz
archive-patched-source.bbclass: Archive patched source
This bbclass inherits archiver.bbclass to archive patched source [YOCTO #1977] Signed-off-by: Xiaofeng Yan <xiaofeng.yan@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/archive-patched-source.bbclass14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/classes/archive-patched-source.bbclass b/meta/classes/archive-patched-source.bbclass
new file mode 100644
index 0000000000..a6d368f2ca
--- /dev/null
+++ b/meta/classes/archive-patched-source.bbclass
@@ -0,0 +1,14 @@
+# This file is for getting archiving packages with patched sources(archive 's' before do_patch stage),logs(archive 'temp' after package_write_rpm),dump data and
+# creating diff file(get all environment variables and functions in building and mapping all content in 's' including patches to xxx.diff.gz.
+# All archived packages will be deployed in ${DEPLOY_DIR}/sources
+
+inherit archiver
+
+# Get archiving package with patched sources including patches
+do_patch[postfuncs] += "do_archive_patched_sources "
+
+# Get archiving package with logs(temp) and scripts(.bb and .inc files)
+do_package_write_rpm[prefuncs] += "do_archive_scripts_logs "
+
+# Get dump date and create diff file
+do_package_write_rpm[postfuncs] += "do_dumpdata_create_diff_gz "