aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2010-10-07 13:45:20 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-07 22:07:45 +0100
commit7b079e1d0842e3a1e18ebc1d1fad8c97c96639eb (patch)
treefb64050b6c3546624d98c6b2fc93b479406b57dc /meta
parentbda24caa5cc22dcac2dbefa2b3cece4a0f810d95 (diff)
downloadopenembedded-core-contrib-7b079e1d0842e3a1e18ebc1d1fad8c97c96639eb.tar.gz
Update meta-ide-support dependencies
Using poky-qemu with our new tap networking and/or unfs support required too many additional build steps. This updates the meta-ide-support dependencies so all features are built and available to use. Specifically, this adds psuedo-native, qemu-helper-native, and unfs-server-native to the dependency chain for meta-ide-support. This fixes [BUGID #392] Also add poky-gen-tapdevs and remove runqemu-nfs from the qemu-helper-native recipe, and update some qemu control script error messages to suggest building meta-ide-support. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb5
-rw-r--r--meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb3
-rw-r--r--meta/recipes-tbd/meta/meta-ide-support.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
index 473411db92..791465694b 100644
--- a/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemu-helper-nativesdk_1.0.bb
@@ -1,19 +1,19 @@
DESCRIPTION = "Qemu helper scripts from Poky"
LICENSE = "GPL"
RDEPENDS = "qemu-nativesdk"
-PR = "r7"
+PR = "r8"
FILESPATH = "${FILE_DIRNAME}/qemu-helper"
SRC_URI = "file://${POKYBASE}/scripts/poky-qemu \
file://${POKYBASE}/scripts/poky-qemu-internal \
file://${POKYBASE}/scripts/poky-addptable2image \
+ file://${POKYBASE}/scripts/poky-gen-tapdevs \
file://${POKYBASE}/scripts/poky-qemu-ifup \
file://${POKYBASE}/scripts/poky-qemu-ifdown \
file://${POKYBASE}/scripts/poky-find-native-sysroot \
file://${POKYBASE}/scripts/poky-extract-sdk \
file://${POKYBASE}/scripts/poky-export-rootfs \
- file://${POKYBASE}/scripts/runqemu-nfs \
file://tunctl.c \
file://raw2flash.c \
"
@@ -31,7 +31,6 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}${POKYBASE}/scripts/poky-* ${D}${bindir}/
- install -m 0755 ${WORKDIR}${POKYBASE}/scripts/runqemu-nfs ${D}${bindir}/
install tunctl ${D}${bindir}/
install raw2flash.spitz ${D}${bindir}/
install flash2raw.spitz ${D}${bindir}/
diff --git a/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
index ecba4525a2..66012189dc 100644
--- a/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
+++ b/meta/recipes-devtools/unfs-server/unfs-server_2.2beta47.bb
@@ -3,7 +3,8 @@ SECTION = "console/network"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-PR = "r0"
+RDEPENDS = "pseudo"
+PR = "r1"
SRC_URI = "ftp://linux.mathematik.tu-darmstadt.de/pub/linux/oldstuff/people/okir/nfs-server-${PV}.tar.gz \
file://001-2.2b47-2.2b51.patch \
diff --git a/meta/recipes-tbd/meta/meta-ide-support.bb b/meta/recipes-tbd/meta/meta-ide-support.bb
index 70a0c64aba..8fe9a23036 100644
--- a/meta/recipes-tbd/meta/meta-ide-support.bb
+++ b/meta/recipes-tbd/meta/meta-ide-support.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
LICENSE = "MIT"
-DEPENDS = "virtual/libc gdb-cross"
+DEPENDS = "virtual/libc gdb-cross qemu-helper-native unfs-server-native"
PR = "r1"
inherit meta toolchain-scripts