aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-09-08 23:06:13 -0700
committerSaul Wold <sgw@linux.intel.com>2012-09-18 07:44:13 -0700
commit76f3a1979ea166238e26a2569fb06a4a403bd864 (patch)
tree7b845e7b34dbadf4727740818c4178bd82385fa7 /meta
parentfddcb9dd086cfb396255ae5c8f717a39c6b9c4b0 (diff)
downloadopenembedded-core-contrib-76f3a1979ea166238e26a2569fb06a4a403bd864.tar.gz
eglibc: Fix fcntl.h for powerpc
This fix is needed for systemd to work on powerpc Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.16/0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch65
-rw-r--r--meta/recipes-core/eglibc/eglibc_2.16.bb1
2 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/eglibc-2.16/0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch b/meta/recipes-core/eglibc/eglibc-2.16/0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch
new file mode 100644
index 0000000000..48b3c56158
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.16/0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch
@@ -0,0 +1,65 @@
+Upstream-Status: Submitted
+
+
+From 4b2716f902c117490285e39deb6ef7925fdc846e Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 8 Sep 2012 19:54:03 -0700
+Subject: [PATCH] Add name_to_handle_at, open_by_handle etc. to PowerPC
+ bits/fcntl.h.
+
+---
+ ChangeLog | 7 +++++++
+ sysdeps/unix/sysv/linux/powerpc/bits/fcntl.h | 28 +++++++++++++++++++++++++-
+ 2 files changed, 34 insertions(+), 1 deletion(-)
+
+Index: libc/sysdeps/unix/sysv/linux/powerpc/bits/fcntl.h
+===================================================================
+--- libc.orig/sysdeps/unix/sysv/linux/powerpc/bits/fcntl.h 2012-09-08 10:27:08.000000000 -0700
++++ libc/sysdeps/unix/sysv/linux/powerpc/bits/fcntl.h 2012-09-08 19:57:44.219191560 -0700
+@@ -1,5 +1,5 @@
+ /* O_*, F_*, FD_* bit values for Linux/PowerPC.
+- Copyright (C) 1995-1998, 2000, 2003, 2004, 2006, 2007, 2009, 2010, 2011
++ Copyright (C) 1995-2012
+ Free Software Foundation, Inc.
+ This file is part of the GNU C Library.
+
+@@ -232,6 +232,19 @@
+ we splice from/to). */
+ # define SPLICE_F_MORE 4 /* Expect more data. */
+ # define SPLICE_F_GIFT 8 /* Pages passed in are a gift. */
++
++
++/* File handle structure. */
++struct file_handle
++{
++ unsigned int handle_bytes;
++ int handle_type;
++ /* File identifier. */
++ unsigned char f_handle[0];
++};
++
++/* Maximum handle size (for now). */
++# define MAX_HANDLE_SZ 128
+ #endif
+
+ __BEGIN_DECLS
+@@ -278,6 +291,19 @@
+ __off64_t __len);
+ # endif
+
++
++/* Map file name to file handle. */
++extern int name_to_handle_at (int __dfd, const char *__name,
++ struct file_handle *__handle, int *__mnt_id,
++ int __flags) __THROW;
++
++/* Open file using the file handle.
++
++ This function is a possible cancellation point and therefore not
++ marked with __THROW. */
++extern int open_by_handle_at (int __mountdirfd, struct file_handle *__handle,
++ int __flags);
++
+ #endif
+
+ __END_DECLS
diff --git a/meta/recipes-core/eglibc/eglibc_2.16.bb b/meta/recipes-core/eglibc/eglibc_2.16.bb
index 78dc44a675..8f3d1594d1 100644
--- a/meta/recipes-core/eglibc/eglibc_2.16.bb
+++ b/meta/recipes-core/eglibc/eglibc_2.16.bb
@@ -29,6 +29,7 @@ SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=h
file://0001-eglibc-menuconfig-support.patch \
file://0002-eglibc-menuconfig-hex-string-options.patch \
file://0003-eglibc-menuconfig-build-instructions.patch \
+ file://0001-Add-name_to_handle_at-open_by_handle-etc.-to-PowerPC.patch \
"
LIC_FILES_CHKSUM = "file://LICENSES;md5=98a1128c4b58120182cbea3b1752d8b9 \
file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \