aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-27 16:12:01 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:46 +0000
commit61620bd56d0696a03ffc94fbbfa2d0e25be950a5 (patch)
treecfa773ed8e51c727f49d151ffe0cf83dd14c46da /meta
parent6ec513e7e6e6959a5eb19f0b06b9e7207fb15ada (diff)
downloadopenembedded-core-contrib-61620bd56d0696a03ffc94fbbfa2d0e25be950a5.tar.gz
python: add md5module support
The internal md5 module is needed for using "waf" to install other python packages such as pycairo. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.2.bb6
-rw-r--r--meta/recipes-devtools/python/python/add-md5module-support.patch18
-rw-r--r--meta/recipes-devtools/python/python_2.7.2.bb3
3 files changed, 24 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.2.bb b/meta/recipes-devtools/python/python-native_2.7.2.bb
index d036eca976..7d8c597447 100644
--- a/meta/recipes-devtools/python/python-native_2.7.2.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.2.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI += "file://04-default-is-optimized.patch \
file://05-enable-ctypes-cross-build.patch \
@@ -11,7 +11,9 @@ SRC_URI += "file://04-default-is-optimized.patch \
file://debug.patch \
file://unixccompiler.patch \
file://nohostlibs.patch \
- file://multilib.patch "
+ file://multilib.patch \
+ file://add-md5module-support.patch \
+ "
S = "${WORKDIR}/Python-${PV}"
inherit native
diff --git a/meta/recipes-devtools/python/python/add-md5module-support.patch b/meta/recipes-devtools/python/python/add-md5module-support.patch
new file mode 100644
index 0000000000..33fea77554
--- /dev/null
+++ b/meta/recipes-devtools/python/python/add-md5module-support.patch
@@ -0,0 +1,18 @@
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+Index: Python-2.7.2/Modules/Setup.dist
+===================================================================
+--- Python-2.7.2.orig/Modules/Setup.dist 2011-06-11 08:46:26.000000000 -0700
++++ Python-2.7.2/Modules/Setup.dist 2011-12-27 15:51:41.244623219 -0800
+@@ -248,7 +248,7 @@
+ # Message-Digest Algorithm, described in RFC 1321. The necessary files
+ # md5.c and md5.h are included here.
+
+-#_md5 md5module.c md5.c
++_md5 md5module.c md5.c
+
+
+ # The _sha module implements the SHA checksum algorithms.
diff --git a/meta/recipes-devtools/python/python_2.7.2.bb b/meta/recipes-devtools/python/python_2.7.2.bb
index 5e8e0d7fa4..654c850759 100644
--- a/meta/recipes-devtools/python/python_2.7.2.bb
+++ b/meta/recipes-devtools/python/python_2.7.2.bb
@@ -1,7 +1,7 @@
require python.inc
DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
DISTRO_SRC_URI ?= "file://sitecustomize.py"
DISTRO_SRC_URI_linuxstdbase = ""
@@ -19,6 +19,7 @@ SRC_URI += "\
file://cgi_py.patch \
file://remove_sqlite_rpath.patch \
file://setup_py_skip_cross_import_check.patch \
+ file://add-md5module-support.patch \
"
S = "${WORKDIR}/Python-${PV}"