aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-02 12:52:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-02 12:52:18 +0100
commit5bcb68a232539cf11a30e3b812b2fbd6d7d76e35 (patch)
tree3399fd08c023029c3c5c43a3ba72b26b21de74a3 /meta
parent78299c87eafbea8331fa062f61095dd8de429109 (diff)
downloadopenembedded-core-contrib-5bcb68a232539cf11a30e3b812b2fbd6d7d76e35.tar.gz
gettext: Fix sysroot conflict over owner of macros
gettext-minimal-native andgettext-native are trampling over each other's files. This can be reproduced with: bitbake gettext-minimal-native bitbake gettext-native bitbake gettext-native -c clean bitbake shadow-native which will fail since the aclocal gettext macros will have disappeared. This patch fixes the problem by giving ownership of them to gettext-minimal-native and ensuring there is a correct dependency on this. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb2
-rw-r--r--meta/recipes-core/gettext/gettext_0.18.1.1.bb8
2 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
index ab4acafa77..d10e3f940a 100644
--- a/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.18.1.1.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0854da868a929923087141d9d7aba7d5"
inherit native
-PR = "r2"
+PR = "r3"
S = "${WORKDIR}"
diff --git a/meta/recipes-core/gettext/gettext_0.18.1.1.bb b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
index 4144d2b51f..46647512fa 100644
--- a/meta/recipes-core/gettext/gettext_0.18.1.1.bb
+++ b/meta/recipes-core/gettext/gettext_0.18.1.1.bb
@@ -5,9 +5,9 @@ SECTION = "libs"
LICENSE = "GPLv3+ & LGPL-2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
-PR = "r10"
+PR = "r11"
DEPENDS = "libxml2-native gettext-native virtual/libiconv ncurses expat"
-DEPENDS_virtclass-native = "libxml2-native"
+DEPENDS_virtclass-native = "libxml2-native gettext-minimal-native"
PROVIDES = "virtual/libintl virtual/gettext"
PROVIDES_virtclass-native = "virtual/gettext-native"
CONFLICTS_${PN} = "proxy-libintl"
@@ -95,4 +95,8 @@ do_install_append() {
rm -f ${D}${libdir}/preloadable_libintl.so
}
+do_install_append_virtclass-native () {
+ rm ${D}${datadir}/aclocal/*
+}
+
BBCLASSEXTEND = "native nativesdk"