aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2012-03-30 17:31:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-02 04:26:09 +0100
commit58ba59f034941bf167e70ae6c08117e5184a20ec (patch)
tree6d33b54f88d8d40582b739f0027c8b67feaa3b94 /meta
parent8f17e499cf91191727c8767e839738cb39c21655 (diff)
downloadopenembedded-core-contrib-58ba59f034941bf167e70ae6c08117e5184a20ec.tar.gz
self-hosted-image: improve do_populate_poky_src
1) remove the assumption ${DL_DIR} ends with downloads/. Thanks Paul Eggleton for pointing this out. 2) remove downloads/git2_* tarballs to speed up the rootfs creation. This is ok since we still have the git2/. Thanks Richard Purdie for suggesting this. Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/self-hosted-image.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-core/images/self-hosted-image.bb b/meta/recipes-core/images/self-hosted-image.bb
index 5aa670d0d9..e962f3049c 100644
--- a/meta/recipes-core/images/self-hosted-image.bb
+++ b/meta/recipes-core/images/self-hosted-image.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-PR = "r6"
+PR = "r7"
CORE_IMAGE_EXTRA_INSTALL = "\
task-self-hosted \
@@ -37,7 +37,12 @@ fakeroot do_populate_poky_src () {
cp -Rp ${WORKDIR}/git ${IMAGE_ROOTFS}/home/builder/poky
mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/conf
- cp -Rp ${DL_DIR} ${IMAGE_ROOTFS}/home/builder/poky/build
+ mkdir -p ${IMAGE_ROOTFS}/home/builder/poky/build/downloads
+ cp -RpL ${DL_DIR}/* ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/
+
+ # Remove the git2_* tarballs -- this is ok since we still have the git2/.
+ rm -rf ${IMAGE_ROOTFS}/home/builder/poky/build/downloads/git2_*
+
echo "/usr/bin" > ${IMAGE_ROOTFS}/home/builder/poky/build/pseudodone
echo "BB_NO_NETWORK = \"1\"" > ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf
echo "INHERIT += \"rm_work\"" >> ${IMAGE_ROOTFS}/home/builder/poky/build/conf/auto.conf