aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-25 13:15:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-26 22:41:49 +0000
commit54c4b4fd10c104641bb7ae087b2230aa6c6085f8 (patch)
tree413398d3d981f3190ac162f1f854fa279f97873d /meta
parent67176378266767cd0cca4f8ecafa865907ca4bdd (diff)
downloadopenembedded-core-contrib-54c4b4fd10c104641bb7ae087b2230aa6c6085f8.tar.gz
ghostscript: Ensure we run reautoconf
Avoding the autoreconf with a hardcoded do_configure is bad practise since it can hide various errors. This patch ensures we do use the standard do_configure. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.04.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.04.bb b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
index 86d5ef2f1a..7178524167 100644
--- a/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
+++ b/meta/recipes-extended/ghostscript/ghostscript_9.04.bb
@@ -15,7 +15,7 @@ SECTION = "console/utils"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d151214b3131251dfc9d858593acbd24"
-PR = "r1"
+PR = "r2"
DEPENDS = "ghostscript-native tiff jpeg fontconfig cups"
DEPENDS_virtclass-native = ""
@@ -44,18 +44,22 @@ BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
inherit autotools
-do_configure () {
- mkdir -p obj
- mkdir -p soobj
- cp ${WORKDIR}/objarch.h obj/arch.h
-
- oe_runconf
+do_configure_prepend () {
+ mkdir -p obj
+ mkdir -p soobj
+ if [ -e ${WORKDIR}/objarch.h ]; then
+ cp ${WORKDIR}/objarch.h obj/arch.h
+ fi
+}
- # copy tools from the native ghostscript build
- mkdir -p obj/aux soobj
- for i in genarch genconf mkromfs echogs gendev genht; do
- cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
- done
+do_configure_append () {
+ # copy tools from the native ghostscript build
+ if [ "${PN}" != "ghostscript-native" ]; then
+ mkdir -p obj/aux soobj
+ for i in genarch genconf mkromfs echogs gendev genht; do
+ cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
+ done
+ fi
}
do_install_append () {
@@ -72,10 +76,6 @@ python do_patch_virtclass-native () {
pass
}
-do_configure_virtclass-native () {
- oe_runconf
-}
-
do_compile_virtclass-native () {
mkdir -p obj
for i in genarch genconf mkromfs echogs gendev genht; do