aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-01-24 09:42:55 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-25 14:32:48 +0000
commit4e8644584aa8826e9cbf9ff0dc23b8c395978013 (patch)
treec9564a14cccd51aaff40a8d0c840a9e0b468c70c /meta
parent5801f480b74465696389783dc651ec48ff42e715 (diff)
downloadopenembedded-core-contrib-4e8644584aa8826e9cbf9ff0dc23b8c395978013.tar.gz
ltp: Update recipe and fix building on uclibc
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/ltp/ltp/uclibc-getcontext.patch78
-rw-r--r--meta/recipes-extended/ltp/ltp_20120104.bb (renamed from meta/recipes-extended/ltp/ltp_20110915.bb)10
2 files changed, 83 insertions, 5 deletions
diff --git a/meta/recipes-extended/ltp/ltp/uclibc-getcontext.patch b/meta/recipes-extended/ltp/ltp/uclibc-getcontext.patch
new file mode 100644
index 0000000000..310e2d4fa6
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp/uclibc-getcontext.patch
@@ -0,0 +1,78 @@
+Fix building disabled getcontext and profil01 tests for uclibc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+
+Index: ltp-20110915/testcases/kernel/syscalls/getcontext/getcontext01.c
+===================================================================
+--- ltp-20110915.orig/testcases/kernel/syscalls/getcontext/getcontext01.c 2012-01-19 16:39:24.391012507 -0800
++++ ltp-20110915/testcases/kernel/syscalls/getcontext/getcontext01.c 2012-01-19 16:39:24.459012510 -0800
+@@ -34,6 +34,10 @@
+ **********************************************************/
+
+ #include <features.h>
++#include "test.h"
++#include "usctest.h"
++char *TCID = "getcontext01"; /* Test program identifier. */
++
+ #if !defined(__UCLIBC__)
+
+ #include <stdio.h>
+@@ -41,13 +45,9 @@
+ #include <errno.h>
+ #include <ucontext.h>
+
+-#include "test.h"
+-#include "usctest.h"
+-
+ void setup();
+ void cleanup();
+
+-char *TCID = "getcontext01"; /* Test program identifier. */
+ int TST_TOTAL = 1; /* Total number of test cases. */
+
+ int exp_enos[] = { 0 }; /* must be a 0 terminated list */
+@@ -102,4 +102,4 @@
+ {
+ tst_brkm(TCONF, NULL, "system doesn't have getcontext support");
+ }
+-#endif
+\ No newline at end of file
++#endif
+Index: ltp-20110915/testcases/kernel/syscalls/profil/profil01.c
+===================================================================
+--- ltp-20110915.orig/testcases/kernel/syscalls/profil/profil01.c 2012-01-19 16:39:55.975014036 -0800
++++ ltp-20110915/testcases/kernel/syscalls/profil/profil01.c 2012-01-19 16:40:23.475015322 -0800
+@@ -41,6 +41,8 @@
+ #endif
+
+ #include <features.h>
++#include "test.h"
++char *TCID = "profil01";
+ #ifndef __UCLIBC__
+
+ #ifdef __arm__
+@@ -58,7 +60,6 @@
+ #include <errno.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+-#include "test.h"
+ #include "usctest.h"
+ #define FAILED 0
+ #define PASSED 1
+@@ -73,7 +74,6 @@
+ //char progname[]= "profil1()";
+
+ /***** LTP Port *****/
+-char *TCID = "profil01";
+ int local_flag = PASSED;
+ int block_number;
+ FILE *temp;
+@@ -310,4 +310,4 @@
+ /* uClibc does not have profiling support */
+ tst_exit();
+ }
+-#endif
+\ No newline at end of file
++#endif
diff --git a/meta/recipes-extended/ltp/ltp_20110915.bb b/meta/recipes-extended/ltp/ltp_20120104.bb
index f1e58b2fc3..07e1fcc0ce 100644
--- a/meta/recipes-extended/ltp/ltp_20110915.bb
+++ b/meta/recipes-extended/ltp/ltp_20120104.bb
@@ -3,8 +3,6 @@ DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, an
HOMEPAGE = "http://ltp.sourceforge.net"
SECTION = "console/utils"
-PR = "r1"
-
LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://testcases/kernel/mce-test/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
@@ -21,10 +19,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
"
-SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.bz2 \
+ file://uclibc-getcontext.patch \
+ "
-SRC_URI[md5sum] = "582fb78d7bf78a624a4387f29327d166"
-SRC_URI[sha256sum] = "013f7f2f6fdf46b7d73216533c3d4c2d91f0a2cec522bf026f7c8920ede83d2c"
+SRC_URI[md5sum] = "ac183bbdac67139f049b3755fda37179"
+SRC_URI[sha256sum] = "11b149b821d709e3351ac66f028f1b0dd5337ee9073dc20019ccffdac42d5c2e"
export prefix = "/opt/ltp"
export exec_prefix = "/opt/ltp"