aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-11-03 08:35:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-07 14:03:25 +0000
commit4c4143e0f0382118448c7c2a452dafac0db5130f (patch)
treebc11c8dfcafc2fd35284e98486f060da93c7658d /meta
parent43213fd610da7b550e6d738e224b49004776f799 (diff)
downloadopenembedded-core-contrib-4c4143e0f0382118448c7c2a452dafac0db5130f.tar.gz
dtc: Add patch to correctly install shared libraries and links
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/dtc/dtc.inc3
-rw-r--r--meta/recipes-kernel/dtc/dtc/make_install.patch15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta/recipes-kernel/dtc/dtc.inc b/meta/recipes-kernel/dtc/dtc.inc
index 0f45d5f08e..9b4b7682b8 100644
--- a/meta/recipes-kernel/dtc/dtc.inc
+++ b/meta/recipes-kernel/dtc/dtc.inc
@@ -7,10 +7,11 @@ DEPENDS = "flex-native bison-native"
inherit autotools
SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git \
+ file://make_install.patch \
"
EXTRA_OEMAKE='PREFIX="${prefix}"'
-INC_PR = "r1"
+INC_PR = "r2"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-kernel/dtc/dtc/make_install.patch b/meta/recipes-kernel/dtc/dtc/make_install.patch
new file mode 100644
index 0000000000..2f7d8091ce
--- /dev/null
+++ b/meta/recipes-kernel/dtc/dtc/make_install.patch
@@ -0,0 +1,15 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile 2011-11-02 14:52:17.243104779 -0700
++++ git/Makefile 2011-11-02 15:06:01.555104982 -0700
+@@ -161,8 +161,8 @@
+ $(INSTALL) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) $(BIN) $(SCRIPTS) $(DESTDIR)$(BINDIR)
+ $(INSTALL) -d $(DESTDIR)$(LIBDIR)
+- $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+- ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++ $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
++ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
+ ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
+ $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
+ $(INSTALL) -d $(DESTDIR)$(INCLUDEDIR)