aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-03-09 09:26:13 +0000
committerKhem Raj <raj.khem@gmail.com>2011-03-08 20:41:18 -0800
commit4bb281ef5f12096d0889ba8efcc3fd3bb0ed3b3c (patch)
treeb709f146adccfc7d4610db71f27f293869345b99 /meta
parentc0ce17aed98c6475b6c1dc18c6655f3a52eda0fa (diff)
downloadopenembedded-core-contrib-4bb281ef5f12096d0889ba8efcc3fd3bb0ed3b3c.tar.gz
gcc-runtime: fix LSB library checks for libstdc++.so.6
[YOCTO #795] When we run library check of LSB on qemux86 and qemuppc, we got some failures about 'libstdc++.so.6'. Test environment: Platform: Qemu-x86, Qemu-ppc lsb image: poky-image-lsb-qemux86-test.ext3(Feb 26th, auto-build server) Library check of LSB: 4.1.0-1 The error log: Did not find _ZNKSt5ctypeIcE8do_widenEPKcS2_Pc (GLIBCXX_3.4) in libstdc++.so.6 Unmangled symbol name: std::ctype<char>::do_widen(char const*, char const*, char*) const ... found that some weak symbols ('W') change into local ('t') during link time and be stripped. According to compiling log, the option "-fvisibility-inlines-hidden" is used for gcc. And this option caused some weak symbols change into local. see http://bugzilla.pokylinux.org/show_bug.cgi?id=795 for more information on the bug. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Jingdong Lu <jingdong.lu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-configure-runtime.inc3
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb2
2 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
index 6cc11e2ffe..2d214afe51 100644
--- a/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-configure-runtime.inc
@@ -1,5 +1,8 @@
require gcc-configure-common.inc
+CXXFLAGS = "${@oe_filter_out('-fvisibility-inlines-hidden',
+'${CXXFLAGS}', d)}"
+
EXTRA_OECONF_PATHS = " \
--with-local-prefix=${STAGING_DIR_TARGET}${prefix} \
--with-gxx-include-dir=${includedir}/c++/ \
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
index 093f9bf963..c1e680d3c0 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
@@ -1,4 +1,4 @@
-PR = "r2"
+PR = "r3"
require gcc-${PV}.inc
require gcc-configure-runtime.inc