aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-02-01 08:24:48 -0800
committerSaul Wold <sgw@linux.intel.com>2011-02-03 11:52:32 -0800
commit3a70078c369def85aca1086ac8ca83d082bb27ec (patch)
treeae5b64dfe80dbd59e55e3aacdec20f8750654c17 /meta
parent8a52fda62fb9e51f51e2504b617890ee9fe8b73a (diff)
downloadopenembedded-core-contrib-3a70078c369def85aca1086ac8ca83d082bb27ec.tar.gz
beagleboard: set kernel provider to linux-yocto (2.6.37)
Support has been added for basic Beagleboard xM functionality, including networking, to the linux-yocto kernel repository. Tested on the Beagleboard xM. Signed-off-by: Darren Hart <dvhart@linux.intel.com> CC: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/machine/beagleboard.conf2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/conf/machine/beagleboard.conf b/meta/conf/machine/beagleboard.conf
index f21638c409..04947c09dc 100644
--- a/meta/conf/machine/beagleboard.conf
+++ b/meta/conf/machine/beagleboard.conf
@@ -24,7 +24,7 @@ EXTRA_IMAGECMD_jffs2 = "-lnp "
# Guesswork
SERIAL_CONSOLE = "115200 ttyO2"
-PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-stable"
+PREFERRED_PROVIDER_virtual/kernel = "linux-yocto"
PREFERRED_PROVIDER_linux-libc-headers ?= "linux-libc-headers-yocto"
KERNEL_IMAGETYPE = "uImage"
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 5f126b37b7..cc52397006 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -20,7 +20,7 @@ SRCREV_FORMAT = "meta_machine"
SRC_URI = "git://git.pokylinux.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta \
file://tools-perf-no-scripting.patch"
-COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro)"
+COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|routerstationpro|beagleboard)"
# Functionality flags
KERNEL_REVISION_CHECKING ?= "t"