aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2007-12-18 15:04:06 +0000
committerRichard Purdie <richard@openedhand.com>2007-12-18 15:04:06 +0000
commit34927dfa61c696442f297c284d546e443ed21485 (patch)
tree64f1c54a57ec1aebb1abb1cee682759d6581e04b /meta
parentce30130b7c9b12a44368a3db4678e31fdc3adca4 (diff)
downloadopenembedded-core-contrib-34927dfa61c696442f297c284d546e443ed21485.tar.gz
Sync various tweaks from OE, change default SRCREV policy to not auto increment rather than hitting the network.
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3345 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/bitbake.conf23
-rw-r--r--meta/packages/autoconf/autoconf_2.61.bb8
-rw-r--r--meta/site/common-glibc7
3 files changed, 27 insertions, 11 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 218e80301c..20425d8050 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -109,7 +109,18 @@ DATETIME = "${DATE}${TIME}"
# python-native should be here but python relies on building
# its own in staging
-ASSUME_PROVIDED = "cvs-native svn-native bzip2-native diffstat-native patch-native python-native-runtime perl-native-runtime texinfo-native util-linux-native grep-native"
+ASSUME_PROVIDED = "\
+ bzip2-native \
+ cvs-native \
+ grep-native \
+ diffstat-native \
+ patch-native \
+ perl-native-runtime \
+ python-native-runtime \
+ svn-native \
+ texinfo-native \
+ util-linux-native \
+ "
##################################################################
# Package default variables.
@@ -438,7 +449,7 @@ UPDATECOMMAND = "ERROR, this must be a BitBake bug"
UPDATECOMMAND_cvs = "/usr/bin/env cvs -d${CVSROOT} update -d -P ${CVSCOOPTS}"
UPDATECOMMAND_svn = "/usr/bin/env svn update ${SVNCOOPTS}"
SRCDATE = "${DATE}"
-SRCREV = "${@bb.fetch.get_srcrev(d)}"
+SRCREV = "1"
AUTOREV = "${@bb.fetch.get_srcrev(d)}"
SRC_URI = "file://${FILE}"
@@ -511,9 +522,10 @@ AUTO_LIBNAME_PKGS = "${PACKAGES}"
# when ${MACHINE} is 'ramses'. And finally '<foo>_local' overrides anything.
#
# This works for functions as well, they are really just environment variables.
-#OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}"
-# Alternative OVERRIDES to make compilation fail fast, we will enable it by default soon
+# Default OVERRIDES to make compilation fail fast in case of build system misconfiguration.
OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}:fail-fast:pn-${PN}"
+# Alternative OVERRIDES definition without "fail fast", usually only for native building and Scratchbox toolchains.
+#OVERRIDES = "local:${MACHINE}:${DISTRO}:${TARGET_OS}:${TARGET_ARCH}:build-${BUILD_OS}:pn-${PN}"
##################################################################
# Include the rest of the config files.
@@ -536,7 +548,8 @@ require conf/sanity.conf
DL_DIR ?= "${TMPDIR}/downloads"
IMAGE_FSTYPES ?= "jffs2"
PCMCIA_MANAGER ?= "pcmcia-cs"
-MACHINE_TASK_PROVIDER ?= "task-base"
+DEFAULT_TASK_PROVIDER ?= "task-base"
+MACHINE_TASK_PROVIDER ?= "${DEFAULT_TASK_PROVIDER}"
IMAGE_ROOTFS_SIZE_ext2 ?= "65536"
IMAGE_ROOTFS_SIZE_ext2.gz ?= "65536"
IMAGE_ROOTFS_SIZE_ext3 ?= "65536"
diff --git a/meta/packages/autoconf/autoconf_2.61.bb b/meta/packages/autoconf/autoconf_2.61.bb
index fe210a1003..6b92dc8120 100644
--- a/meta/packages/autoconf/autoconf_2.61.bb
+++ b/meta/packages/autoconf/autoconf_2.61.bb
@@ -2,6 +2,8 @@ require autoconf.inc
PR = "r1"
+PARALLEL_MAKE = ""
+
DEPENDS += "m4-native"
RDEPENDS_${PN} = "m4 gnu-config"
@@ -12,9 +14,3 @@ SRC_URI += "file://autoreconf-include.patch;patch=1 \
file://autoheader-nonfatal-warnings.patch;patch=1 \
file://config-site.patch;patch=1 \
${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
-
-#
-# without it build break:
-# | make[1]: *** No rule to make target `../bin/autom4te', needed by `autoconf.in'. Stop.
-#
-PARALLEL_MAKE = ""
diff --git a/meta/site/common-glibc b/meta/site/common-glibc
index 362fe538cd..0ec53423f1 100644
--- a/meta/site/common-glibc
+++ b/meta/site/common-glibc
@@ -37,3 +37,10 @@ ac_cv_func_pthread_attr_getstack=${ac_cv_func_pthread_attr_getstack=yes}
ac_cv_func_getpagesize=${ac_cv_func_getpagesize=yes}
ac_cv_func_memcpy=${ac_cv_func_memcpy=yes}
ac_cv_func_strerror=${ac_cv_func_strerror=yes}
+
+# squid
+ac_cv_af_unix_large_dgram=${ac_cv_af_unix_large_dgram=yes}
+ac_cv_func_setresuid=${ac_cv_func_setresuid=yes}
+ac_cv_func_va_copy=${ac_cv_func_va_copy=yes}
+ac_cv_func___va_copy=${ac_cv_func___va_copy=yes}
+ac_cv_epoll_works=${ac_cv_epoll_works=yes}