aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-10-04 13:29:44 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-07 22:11:36 +0100
commit2e040618978b93d0add0e7e115c17545685c9dfc (patch)
tree6164f28e31250133db832fe79d53d8b0acb2b4ec /meta
parent7b079e1d0842e3a1e18ebc1d1fad8c97c96639eb (diff)
downloadopenembedded-core-contrib-2e040618978b93d0add0e7e115c17545685c9dfc.tar.gz
cross-localedef-native: tool for cross generation of locales
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.12.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.12.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.12.bb
new file mode 100644
index 0000000000..a12779d3a1
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.12.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Cross locale generation tool for eglibc"
+HOMEPAGE = "http://www.eglibc.org/home"
+SECTION = "libs"
+PRIORITY = "required"
+LICENSE = "LGPL"
+
+inherit native
+inherit autotools
+
+PR = "r0"
+SRCREV="10809"
+EGLIBC_BRANCH="eglibc-2_12"
+SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
+S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
+
+do_unpack_append() {
+ bb.build.exec_func('do_move_ports', d)
+}
+
+do_move_ports() {
+ if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
+ rm -rf ${S}../libc/ports
+ mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/../libc/
+ fi
+}
+
+EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
+
+do_configure () {
+ ./configure ${EXTRA_OECONF}
+}
+
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
+}