aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2012-11-01 14:47:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-02 16:15:30 +0000
commit2bda4bbda3f3033cfb324778ef88f2aedad4a83b (patch)
tree7be5b31144941e5fb867e402643f83117ac94671 /meta
parentbb67ddeb2eed3e25c626a279ef53a7e8c7bfe6f2 (diff)
downloadopenembedded-core-contrib-2bda4bbda3f3033cfb324778ef88f2aedad4a83b.tar.gz
hwclock.sh: improve hwclock.sh script to use UTC variable
Make UTC variable in /etc/default/rcS has effect on hwclock.sh. This variable declares whether the Hardware Clock is kept in UTC or local time. Default its value to "yes" and change the comment. [YOCTO #3341] Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/busybox/busybox_1.20.2.bb2
-rw-r--r--meta/recipes-core/busybox/files/hwclock.sh9
-rw-r--r--meta/recipes-core/sysvinit/sysvinit/rcS-default4
-rw-r--r--meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb2
4 files changed, 9 insertions, 8 deletions
diff --git a/meta/recipes-core/busybox/busybox_1.20.2.bb b/meta/recipes-core/busybox/busybox_1.20.2.bb
index 4c0946af1f..3e628d239e 100644
--- a/meta/recipes-core/busybox/busybox_1.20.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.20.2.bb
@@ -1,5 +1,5 @@
require busybox.inc
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://B921600.patch \
diff --git a/meta/recipes-core/busybox/files/hwclock.sh b/meta/recipes-core/busybox/files/hwclock.sh
index 2e50425ba8..cc6d2862ba 100644
--- a/meta/recipes-core/busybox/files/hwclock.sh
+++ b/meta/recipes-core/busybox/files/hwclock.sh
@@ -22,6 +22,7 @@
. /etc/default/rcS
+[ "$UTC" = "yes" ] && tz="--utc" || tz="--localtime"
case "$1" in
start)
if [ "$VERBOSE" != no ]
@@ -34,9 +35,9 @@ case "$1" in
then
if [ -z "$TZ" ]
then
- hwclock --hctosys
+ hwclock $tz --hctosys
else
- TZ="$TZ" hwclock --hctosys
+ TZ="$TZ" hwclock $tz --hctosys
fi
fi
@@ -59,7 +60,7 @@ case "$1" in
fi
if [ "$HWCLOCKACCESS" != no ]
then
- hwclock --systohc
+ hwclock $tz --systohc
fi
if [ "$VERBOSE" != no ]
then
@@ -70,7 +71,7 @@ case "$1" in
show)
if [ "$HWCLOCKACCESS" != no ]
then
- hwclock --show
+ hwclock $tz --show
fi
;;
*)
diff --git a/meta/recipes-core/sysvinit/sysvinit/rcS-default b/meta/recipes-core/sysvinit/sysvinit/rcS-default
index fc6d41522e..3c9dea90c4 100644
--- a/meta/recipes-core/sysvinit/sysvinit/rcS-default
+++ b/meta/recipes-core/sysvinit/sysvinit/rcS-default
@@ -9,8 +9,8 @@ SULOGIN=no
# Set to no if you want to be able to login over telnet/rlogin
# before system startup is complete (as soon as inetd is started)
DELAYLOGIN=no
-# Set UTC=yes if your system clock is set to UTC (GMT), and UTC=no if not.
-# UTC=yes
+# Assume that the BIOS clock is set to UTC time (recommended)
+UTC=yes
# Set VERBOSE to "no" if you would like a more quiet bootup.
VERBOSE=no
# Set EDITMOTD to "no" if you don't want /etc/motd to be edited automatically
diff --git a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
index 63333b06f4..1647a0fc3a 100644
--- a/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
+++ b/meta/recipes-core/sysvinit/sysvinit_2.88dsf.bb
@@ -5,7 +5,7 @@ SECTION = "base"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYRIGHT;endline=15;md5=349c872e0066155e1818b786938876a4"
-PR = "r7"
+PR = "r8"
RDEPENDS_${PN} = "${PN}-inittab"