aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-03-10 17:52:20 -0600
committerSaul Wold <sgw@linux.intel.com>2011-03-10 18:16:07 -0800
commit285fbd8a206eee061e27f37430499fcbe1e7284d (patch)
tree5a576078e17074bdd5d9571bebc658131daae5c1 /meta
parent1d5ca654a482f582c75faf546140dfd6064da73b (diff)
downloadopenembedded-core-contrib-285fbd8a206eee061e27f37430499fcbe1e7284d.tar.gz
gcc-runtime: Fix dbg files
In order to debug certain C++ items, you need the helper python components. These components should live in the -dbg package, ensure they are added to the recipe. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-package-runtime.inc5
-rw-r--r--meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb2
2 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-package-runtime.inc b/meta/recipes-devtools/gcc/gcc-package-runtime.inc
index 04c70c0e4f..51483f9980 100644
--- a/meta/recipes-devtools/gcc/gcc-package-runtime.inc
+++ b/meta/recipes-devtools/gcc/gcc-package-runtime.inc
@@ -15,6 +15,11 @@ PACKAGES = "\
# The base package doesn't exist, so we clear the recommends.
RRECOMMENDS_${PN}-dbg = ""
+# include python debugging scripts
+FILES_${PN}-dbg += "\
+ ${libdir}/libstdc++.so.*-gdb.py \
+ ${datadir}/gcc-${PV}/python/libstdcxx"
+
FILES_libg2c = "${target_libdir}/libg2c.so.*"
FILES_libg2c-dev = "\
${libdir}/libg2c.so \
diff --git a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
index c1e680d3c0..9eb658b12c 100644
--- a/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc-runtime_4.5.1.bb
@@ -1,4 +1,4 @@
-PR = "r3"
+PR = "r4"
require gcc-${PV}.inc
require gcc-configure-runtime.inc