aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2012-02-21 17:46:43 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-22 22:10:40 +0000
commit264d1254e5ac11613af06c0f1c53c736f54e9f54 (patch)
treeb27b2fa46e4c71c3da26f30df996cf56167d09d6 /meta
parentbf440fd971dd549ae4e92c54046ea062ef51cd85 (diff)
downloadopenembedded-core-contrib-264d1254e5ac11613af06c0f1c53c736f54e9f54.tar.gz
external-csl-toolchain: skip parsing if CSL_VER_MAIN isn't set
Signed-off-by: Joshua Lock <josh@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/meta/external-csl-toolchain.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/external-csl-toolchain.bb b/meta/recipes-core/meta/external-csl-toolchain.bb
index d15578bf78..07c3e3065a 100644
--- a/meta/recipes-core/meta/external-csl-toolchain.bb
+++ b/meta/recipes-core/meta/external-csl-toolchain.bb
@@ -150,3 +150,11 @@ FILES_linux-libc-headers = "${includedir}/asm* \
"
FILES_gdbserver = "${bindir}/gdbserver ${libdir}/bin/sysroot-gdbserver"
FILES_gdbserver-dbg = "${bindir}/.debug/gdbserver"
+
+CSL_VER_MAIN ??= ""
+
+python () {
+ if not d.getVar("CSL_VER_MAIN"):
+ raise bb.parse.SkipPackage("External CSL toolchain not configured (CSL_VER_MAIN not set).")
+}
+