aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-07-20 23:10:13 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-22 11:48:50 +0100
commit172e8de050673bedd1d7a17e5b9bd099448e20fa (patch)
tree496f4e6bb336d4c7690f07e07724791e3ee4bf8f /meta
parent1a55faf994b30101026b6c8980023f213ee1db2c (diff)
downloadopenembedded-core-contrib-172e8de050673bedd1d7a17e5b9bd099448e20fa.tar.gz
task-core-tools.bb: Exclude lttng-ust for x86_64/uclibc
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/tasks/task-core-tools.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta/recipes-core/tasks/task-core-tools.bb b/meta/recipes-core/tasks/task-core-tools.bb
index eed4afb69e..b0eb7d46e6 100644
--- a/meta/recipes-core/tasks/task-core-tools.bb
+++ b/meta/recipes-core/tasks/task-core-tools.bb
@@ -58,6 +58,15 @@ RRECOMMENDS_task-core-tools-profile = "\
SYSTEMTAP = "systemtap"
SYSTEMTAP_libc-uclibc = ""
+# lttng-ust uses sched_getcpu() which is not there on uclibc
+# for some of the architectures it can be patched to call the
+# syscall directly but for x86_64 __NR_getcpu is a vsyscall
+# which means we can not use syscall() to call it. So we ignore
+# it for x86_64/uclibc
+
+LTTNGUST = "lttng-ust"
+LTTNGUST_libc-uclibc = ""
+
# exmap-console
# exmap-server
@@ -66,7 +75,7 @@ SYSTEMTAP_libc-uclibc = ""
# (which is required by lttng-ust) may not build on other platforms, like
# MIPS.
RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust ${SYSTEMTAP}"
-RDEPENDS_task-core-tools-profile_append_qemux86-64 = " lttng-ust ${SYSTEMTAP}"
+RDEPENDS_task-core-tools-profile_append_qemux86-64 = " ${LTTNGUST} ${SYSTEMTAP}"
RDEPENDS_task-core-tools-profile_append_qemuppc = " lttng-ust ${SYSTEMTAP}"
RDEPENDS_task-core-tools-profile_append_qemuarm = " lttng-ust"