aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKumar Gala <galak@kernel.crashing.org>2011-08-24 00:08:50 -0500
committerSaul Wold <sgw@linux.intel.com>2011-08-26 12:23:56 -0700
commit0fabe078a31591f41c3fdabe5aa9de1111ef82c7 (patch)
tree72ee0a1c6e73cb7d681869ad0314561908b2b6a7 /meta
parent81aa4bfbde871af1d569b64499c34a315bf6218e (diff)
downloadopenembedded-core-contrib-0fabe078a31591f41c3fdabe5aa9de1111ef82c7.tar.gz
gcc-4.6: Drop gcc-poison-parameters.patch as its not need
The gcc-poison-parameters was added specifically to deal with an issue on ppc targets and a bug when we build with -Os -frename-registers. This bug below reports the issue and is fixed in gcc-4.6.x: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=44618 Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6.inc3
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-parameters.patch76
2 files changed, 1 insertions, 78 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6.inc b/meta/recipes-devtools/gcc/gcc-4.6.inc
index 28a70f3c08..290d8f289c 100644
--- a/meta/recipes-devtools/gcc/gcc-4.6.inc
+++ b/meta/recipes-devtools/gcc/gcc-4.6.inc
@@ -1,6 +1,6 @@
require gcc-common.inc
-PR = "r7"
+PR = "r8"
# Third digit in PV should be incremented after a minor release
# happens from this branch on gcc e.g. currently its 4.6.0
@@ -62,7 +62,6 @@ SRC_URI = "svn://gcc.gnu.org/svn/gcc/branches;module=${BRANCH};proto=http \
file://64bithack.patch \
file://optional_libstdc.patch \
file://disable_relax_pic_calls_flag.patch \
- file://gcc-poison-parameters.patch \
file://GPLUSPLUS_INCLUDE_DIR_with_sysroot.patch \
file://COLLECT_GCC_OPTIONS.patch \
file://volatile_access_backport.patch \
diff --git a/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-parameters.patch b/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-parameters.patch
deleted file mode 100644
index 58bf32fd02..0000000000
--- a/meta/recipes-devtools/gcc/gcc-4.6/gcc-poison-parameters.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-Upstream-Status: Pending
-
-gcc: add poison parameters detection
-
-Add the logic that, if not configured with "--enable-target-optspace",
-gcc will meet error when build target app with "-Os" option.
-This could avoid potential binary crash.
-
-Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
-
-Index: gcc-4.6.0/gcc/config.in
-===================================================================
---- gcc-4.6.0.orig/gcc/config.in
-+++ gcc-4.6.0/gcc/config.in
-@@ -150,6 +150,12 @@
- #endif
-
-
-+/* Define to enable target optspace support. */
-+#ifndef USED_FOR_TARGET
-+#undef ENABLE_TARGET_OPTSPACE
-+#endif
-+
-+
- /* Define if you want all operations on RTL (the basic data structure of the
- optimizer and back end) to be checked for dynamic type safety at runtime.
- This is quite expensive. */
-Index: gcc-4.6.0/gcc/configure
-===================================================================
---- gcc-4.6.0.orig/gcc/configure
-+++ gcc-4.6.0/gcc/configure
-@@ -26434,6 +26434,13 @@ $as_echo "#define ENABLE_LIBQUADMATH_SUP
- fi
-
-
-+if test x"$enable_target_optspace" != x; then :
-+
-+$as_echo "#define ENABLE_TARGET_OPTSPACE 1" >>confdefs.h
-+
-+fi
-+
-+
- # Configure the subdirectories
- # AC_CONFIG_SUBDIRS($subdirs)
-
-Index: gcc-4.6.0/gcc/configure.ac
-===================================================================
---- gcc-4.6.0.orig/gcc/configure.ac
-+++ gcc-4.6.0/gcc/configure.ac
-@@ -4907,6 +4907,11 @@ if test "${ENABLE_LIBQUADMATH_SUPPORT}"
- fi
-
-
-+AC_SUBST(enable_target_optspace)
-+if test x"$enable_target_optspace" != x; then
-+ AC_DEFINE(ENABLE_TARGET_OPTSPACE, 1, [Define to enable target optspace support.])
-+fi
-+
- # Configure the subdirectories
- # AC_CONFIG_SUBDIRS($subdirs)
-
-Index: gcc-4.6.0/gcc/opts.c
-===================================================================
---- gcc-4.6.0.orig/gcc/opts.c
-+++ gcc-4.6.0/gcc/opts.c
-@@ -605,6 +605,10 @@ default_options_optimization (struct gcc
- maybe_set_param_value (PARAM_MIN_CROSSJUMP_INSNS,
- default_param_value (PARAM_MIN_CROSSJUMP_INSNS),
- opts->x_param_values, opts_set->x_param_values);
-+#ifndef ENABLE_TARGET_OPTSPACE
-+ if (optimize_size == 1)
-+ error ("Do not use -Os option if --enable-target-optspace is not set.");
-+#endif
-
- /* Allow default optimizations to be specified on a per-machine basis. */
- maybe_default_options (opts, opts_set,