aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-02-03 14:42:29 -0800
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:15 -0800
commit086679cfbc30dba4af2f650984084195e5171b8f (patch)
tree9f42d74d457a8d10aa204272ae761bc522ad97ac /meta
parent25016d158af927e0c9e70c3df4674f53fa54fec8 (diff)
downloadopenembedded-core-contrib-086679cfbc30dba4af2f650984084195e5171b8f.tar.gz
libdrm: Fix build failure unearthed by uclibc
uclibc wants to know value of __USE_GNU for certain header prototypes to be enabled. So we move the config.h header up in search list. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-graphics/drm/libdrm/GNU_SOURCE_definition.patch30
-rw-r--r--meta/recipes-graphics/drm/libdrm_2.4.30.bb6
2 files changed, 34 insertions, 2 deletions
diff --git a/meta/recipes-graphics/drm/libdrm/GNU_SOURCE_definition.patch b/meta/recipes-graphics/drm/libdrm/GNU_SOURCE_definition.patch
new file mode 100644
index 0000000000..8eb1d5e1ea
--- /dev/null
+++ b/meta/recipes-graphics/drm/libdrm/GNU_SOURCE_definition.patch
@@ -0,0 +1,30 @@
+uclibc headers need to know if _GNU_SOURCE is defined or not and its defined
+in config.h so include it first to get the definition if its there fixed build
+problems on uclibc
+
+test_decode.c:107:2: error: implicit declaration of function 'open_memstream' [-Werror=implicit-function-declaration]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: libdrm-2.4.30/intel/test_decode.c
+===================================================================
+--- libdrm-2.4.30.orig/intel/test_decode.c 2012-02-03 14:28:46.409355918 -0800
++++ libdrm-2.4.30/intel/test_decode.c 2012-02-03 14:29:02.357356689 -0800
+@@ -21,6 +21,8 @@
+ * IN THE SOFTWARE.
+ */
+
++#include "config.h"
++
+ #include <string.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+@@ -31,7 +33,6 @@
+ #include <sys/mman.h>
+ #include <err.h>
+
+-#include "config.h"
+ #include "intel_bufmgr.h"
+ #include "intel_chipset.h"
+
diff --git a/meta/recipes-graphics/drm/libdrm_2.4.30.bb b/meta/recipes-graphics/drm/libdrm_2.4.30.bb
index 4a6052d211..5d999165e8 100644
--- a/meta/recipes-graphics/drm/libdrm_2.4.30.bb
+++ b/meta/recipes-graphics/drm/libdrm_2.4.30.bb
@@ -2,9 +2,11 @@ require libdrm.inc
LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
-PR = "r0"
+PR = "r1"
-SRC_URI += "file://installtests.patch"
+SRC_URI += "file://installtests.patch \
+ file://GNU_SOURCE_definition.patch \
+ "
SRC_URI[md5sum] = "9f57a68b2c0836b55ebcbc241f6ca175"
SRC_URI[sha256sum] = "cacea9c157ec824ad278a06f4910659b2f3ae69686518ece8d6967843cddcd56"