aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-08-24 11:34:29 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 13:04:38 +0100
commit084eb5a04dc684f5558401a2d77550d5dfc057b4 (patch)
treec6d71f2b2a71dbf4003ecc6968286d3006225e31 /meta
parent9f03fdd5c749cf7b9a971ffbf610bc4f001853af (diff)
downloadopenembedded-core-contrib-084eb5a04dc684f5558401a2d77550d5dfc057b4.tar.gz
rsync: split GPLv2 version from GPLv3 by fixing the GPLv2 recipe
remove the "require rsync.inc", and copy the .inc file into the GPLv2 recipe, and adjust it properly; mkdir rsync-2.6.9 and copy files/rsyncd.conf into rsync-2.6.9/rsyncd.conf. BTW: the .conf file originated from OE in 2006: commit c2a4b021eb04924f8c8b0e0af1fac337a04cbcae Author: Raymond Danks <raymond@edanks.com> Date: Tue Apr 18 01:43:08 2006 +0000 rsync: Add rsyncd.conf http://cgit.openembedded.org/cgit.cgi/openembedded/commit/?id=c2a4b021eb04924f8c8b0e0af1fac337a04cbcae Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/rsync/rsync-2.6.9/rsyncd.conf15
-rw-r--r--meta/packages/rsync/rsync_2.6.9.bb23
2 files changed, 36 insertions, 2 deletions
diff --git a/meta/packages/rsync/rsync-2.6.9/rsyncd.conf b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf
new file mode 100644
index 0000000000..845f5b33f5
--- /dev/null
+++ b/meta/packages/rsync/rsync-2.6.9/rsyncd.conf
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+# path = /
+# comment = Everything except /etc exposed
+# exclude = /etc
diff --git a/meta/packages/rsync/rsync_2.6.9.bb b/meta/packages/rsync/rsync_2.6.9.bb
index a9b5c86d8f..43379829ea 100644
--- a/meta/packages/rsync/rsync_2.6.9.bb
+++ b/meta/packages/rsync/rsync_2.6.9.bb
@@ -1,6 +1,25 @@
-require rsync.inc
+DESCRIPTION = "A file-synchronization tool"
+HOMEPAGE = "http://rsync.samba.org/"
+BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
+SECTION = "console/network"
+PRIORITY = "optional"
+
+# needs to add acl and attr
+DEPENDS = "popt"
+
+SRC_URI = "http://rsync.samba.org/ftp/rsync/src/rsync-${PV}.tar.gz \
+ file://rsyncd.conf"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}/etc
+ install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
+EXTRA_OEMAKE='STRIP=""'
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=6d5a9d4c4d3af25cd68fd83e8a8cb09c"
-PR = "r1"
+PR = "r2"