aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-03-07 17:17:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-15 11:15:32 +0000
commit05d9c6646d4d5bb174e42c3a6e36bcdad1657da3 (patch)
tree0c653307a4a27f8f2d4d10dda22cb0a80aa7726c /meta
parente906c6ea72b0edcc509a2ef5f44cba5584432dd1 (diff)
downloadopenembedded-core-contrib-05d9c6646d4d5bb174e42c3a6e36bcdad1657da3.tar.gz
util-linux: remove unused files from files directory
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/util-linux/files/debian-bug392236.patch203
-rw-r--r--meta/recipes-core/util-linux/files/fdiskbsdlabel_thumb.diff12
-rw-r--r--meta/recipes-core/util-linux/files/fix-make-c.patch41
-rw-r--r--meta/recipes-core/util-linux/files/gcc34.patch23
-rw-r--r--meta/recipes-core/util-linux/files/glibc-fix.patch22
-rw-r--r--meta/recipes-core/util-linux/files/optional-uuid.patch55
-rw-r--r--meta/recipes-core/util-linux/files/umount.diff19
-rw-r--r--meta/recipes-core/util-linux/files/uuid.patch22
8 files changed, 0 insertions, 397 deletions
diff --git a/meta/recipes-core/util-linux/files/debian-bug392236.patch b/meta/recipes-core/util-linux/files/debian-bug392236.patch
deleted file mode 100644
index fcd2046e34..0000000000
--- a/meta/recipes-core/util-linux/files/debian-bug392236.patch
+++ /dev/null
@@ -1,203 +0,0 @@
-Index: util-linux-2.12r/fdisk/llseek.c
-===================================================================
---- util-linux-2.12r.orig/fdisk/llseek.c 2003-07-13 23:13:33.000000000 +0200
-+++ util-linux-2.12r/fdisk/llseek.c 2007-04-04 19:01:14.000000000 +0200
-@@ -14,30 +14,23 @@
-
- #ifdef __linux__
-
--#ifdef HAVE_LLSEEK
--#include <syscall.h>
--
--#else /* HAVE_LLSEEK */
-+#include <sys/syscall.h>
-+#ifndef HAVE_LLSEEK
-
- #if defined(__alpha__) || defined(__ia64__) || defined(__s390x__)
-
- #define my_llseek lseek
-
- #else
--#include <linux/unistd.h> /* for __NR__llseek */
--
--static int _llseek (unsigned int, unsigned long,
-- unsigned long, long long *, unsigned int);
-
--#ifdef __NR__llseek
-+#ifdef SYS__llseek
-
--static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
-- unsigned long, offset_low,long long *,result,
-- unsigned int, origin)
-+#define _llseek(fd, offset_high, offset_low, result, origin) \
-+ syscall(SYS__llseek, fd, offset_high, offset_low, result, origin)
-
- #else
-
--/* no __NR__llseek on compilation machine - might give it explicitly */
-+/* no SYS__llseek on compilation machine - might give it explicitly */
- static int _llseek (unsigned int fd, unsigned long oh,
- unsigned long ol, long long *result,
- unsigned int origin) {
-Index: util-linux-2.12r/fdisk/sfdisk.c
-===================================================================
---- util-linux-2.12r.orig/fdisk/sfdisk.c 2005-01-04 23:31:57.000000000 +0100
-+++ util-linux-2.12r/fdisk/sfdisk.c 2007-04-04 19:01:14.000000000 +0200
-@@ -48,7 +48,7 @@
- #include <sys/ioctl.h>
- #include <sys/stat.h>
- #include <sys/utsname.h>
--#include <linux/unistd.h> /* _syscall */
-+#include <sys/syscall.h>
- #include "nls.h"
- #include "common.h"
-
-@@ -177,9 +177,8 @@
- #endif
-
- #ifndef use_lseek
--static __attribute__used
--_syscall5(int, _llseek, unsigned int, fd, ulong, hi, ulong, lo,
-- loff_t *, res, unsigned int, wh);
-+#define _llseek(fd, hi, lo, res, wh) \
-+ syscall(SYS__llseek, fd, hi, lo, res, wh)
- #endif
-
- static int
-Index: util-linux-2.12r/lib/my_reboot.c
-===================================================================
---- util-linux-2.12r.orig/lib/my_reboot.c 1999-07-09 04:56:36.000000000 +0200
-+++ util-linux-2.12r/lib/my_reboot.c 2007-04-04 19:01:14.000000000 +0200
-@@ -23,10 +23,11 @@
- #else /* no USE_LIBC */
-
- /* direct syscall version */
--#include <linux/unistd.h>
-+#include <sys/syscall.h>
-
--#ifdef _syscall3
--_syscall3(int, reboot, int, magic, int, magic_too, int, cmd);
-+#ifdef SYS_reboot
-+#define reboot(magic, magic2, cmd) \
-+ syscall(SYS_reboot, magic, magic2, cmd)
- #else
- /* Let us hope we have a 3-argument reboot here */
- extern int reboot(int, int, int);
-Index: util-linux-2.12r/misc-utils/setterm.c
-===================================================================
---- util-linux-2.12r.orig/misc-utils/setterm.c 2003-10-17 18:17:51.000000000 +0200
-+++ util-linux-2.12r/misc-utils/setterm.c 2007-04-04 19:01:14.000000000 +0200
-@@ -119,14 +119,13 @@
-
- #if __GNU_LIBRARY__ < 5
- #ifndef __alpha__
--# include <linux/unistd.h>
--#define __NR_klogctl __NR_syslog
--_syscall3(int, klogctl, int, type, char*, buf, int, len);
-+# include <sys/syscall.h>
-+#define klogctl(type, buf, len) \
-+ syscall(SYS_syslog, type, buf, len)
- #else /* __alpha__ */
- #define klogctl syslog
- #endif
- #endif
--extern int klogctl(int type, char *buf, int len);
-
- /* Constants. */
-
-Index: util-linux-2.12r/mount/swapon.c
-===================================================================
---- util-linux-2.12r.orig/mount/swapon.c 2004-12-22 10:50:19.000000000 +0100
-+++ util-linux-2.12r/mount/swapon.c 2007-04-04 19:01:14.000000000 +0200
-@@ -82,11 +82,11 @@
- #else
- /* We want a swapon with two args, but have an old libc.
- Build the kernel call by hand. */
--#include <linux/unistd.h>
--static
--_syscall2(int, swapon, const char *, path, int, flags);
--static
--_syscall1(int, swapoff, const char *, path);
-+#include <sys/syscall.h>
-+#define swapon(path, flags) \
-+ syscall(SYS_swapon, path, flags)
-+#define swapoff(path) \
-+ syscall(SYS_swapoff, path)
- #endif
- #else
- /* just do as libc says */
-Index: util-linux-2.12r/mount/umount.c
-===================================================================
---- util-linux-2.12r.orig/mount/umount.c 2007-04-04 19:01:14.000000000 +0200
-+++ util-linux-2.12r/mount/umount.c 2007-04-04 19:02:22.000000000 +0200
-@@ -37,14 +37,13 @@
- #else /* MNT_FORCE */
-
- /* Does the present kernel source know about umount2? */
--#include <linux/unistd.h>
--#ifdef __NR_umount2
-+#include <sys/syscall.h>
-+#ifdef SYS_umount2
-
--int umount2(const char *path, int flags);
-+#define umount2(path, flags) \
-+ syscall(SYS_umount2, path, flags)
-
--_syscall2(int, umount2, const char *, path, int, flags);
--
--#else /* __NR_umount2 */
-+#else /* SYS_umount2 */
-
- static int
- umount2(const char *path, int flags) {
-@@ -52,7 +51,7 @@
- errno = ENOSYS;
- return -1;
- }
--#endif /* __NR_umount2 */
-+#endif /* SYS_umount2 */
-
- #if !defined(MNT_FORCE)
- /* dare not try to include <linux/mount.h> -- lots of errors */
-Index: util-linux-2.12r/partx/partx.c
-===================================================================
---- util-linux-2.12r.orig/partx/partx.c 2004-08-23 22:13:27.000000000 +0200
-+++ util-linux-2.12r/partx/partx.c 2007-04-04 19:01:14.000000000 +0200
-@@ -338,10 +338,9 @@
- #endif
-
- #ifdef NEED__llseek
--#include <linux/unistd.h> /* _syscall */
--static
--_syscall5(int, _llseek, uint, fd, ulong, hi, ulong, lo,
-- long long *, res, uint, wh);
-+#include <sys/syscall.h>
-+#define _llseek(fd, hi, lo, res, wh) \
-+ syscall(SYS__llseek, fd, hi, lo, res, wh)
- #endif
-
- static int
-Index: util-linux-2.12r/sys-utils/dmesg.c
-===================================================================
---- util-linux-2.12r.orig/sys-utils/dmesg.c 2004-05-04 18:38:12.000000000 +0200
-+++ util-linux-2.12r/sys-utils/dmesg.c 2007-04-04 19:01:14.000000000 +0200
-@@ -29,7 +29,7 @@
- * Only function 3 is allowed to non-root processes.
- */
-
--#include <linux/unistd.h>
-+#include <sys/syscall.h>
- #include <stdio.h>
- #include <getopt.h>
- #include <stdlib.h>
-@@ -38,8 +38,8 @@
- #if __GNU_LIBRARY__ < 5
-
- #ifndef __alpha__
--# define __NR_klogctl __NR_syslog
-- static inline _syscall3(int, klogctl, int, type, char *, b, int, len);
-+# define klogctl(type, b, len) \
-+ syscall(SYS_syslog, type, b, len)
- #else /* __alpha__ */
- #define klogctl syslog
- #endif
diff --git a/meta/recipes-core/util-linux/files/fdiskbsdlabel_thumb.diff b/meta/recipes-core/util-linux/files/fdiskbsdlabel_thumb.diff
deleted file mode 100644
index e6f82b5b46..0000000000
--- a/meta/recipes-core/util-linux/files/fdiskbsdlabel_thumb.diff
+++ /dev/null
@@ -1,12 +0,0 @@
---- util-linux-2.12r/fdisk/fdiskbsdlabel.h.orig 2006-01-21 23:53:51.000000000 +0100
-+++ util-linux-2.12r/fdisk/fdiskbsdlabel.h 2006-01-21 23:54:35.000000000 +0100
-@@ -52,6 +52,9 @@
- #elif defined (__s390__) || defined (__s390x__)
- #define BSD_LABELSECTOR 1
- #define BSD_LABELOFFSET 0
-+#elif defined (__thumb__)
-+#define BSD_LABELSECTOR 1
-+#define BSD_LABELOFFSET 0
- #else
- #error unknown architecture
- #endif
diff --git a/meta/recipes-core/util-linux/files/fix-make-c.patch b/meta/recipes-core/util-linux/files/fix-make-c.patch
deleted file mode 100644
index bf1082e85c..0000000000
--- a/meta/recipes-core/util-linux/files/fix-make-c.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From: Karel Zak <kzak@redhat.com>
-Date: Mon, 11 May 2009 09:49:00 +0000 (+0200)
-Subject: build-sys: fix "make -C" bug
-X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=2ef7d41e6bbb7c842c06e911ffc562335a467b5d
-
-build-sys: fix "make -C" bug
-
-Running:
-
-./configure --with-fsprobe=builtin
-make -C mount mount
-
-causes the following error:
-
-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I.. -include ../config.h
--I../include -DLOCALEDIR=\"/home/matthew/util-linux-ng/share/locale\"
--fsigned-char -I../libs/blkid/src -g -O2 -MT mount-setproctitle.o
--MD -MP -MF .deps/mount-setproctitle.Tpo -c -o mount-setproctitle.o
-`test -f '../lib/setproctitle.c' || echo './'`../lib/setproctitle.c mv
--f .deps/mount-setproctitle.Tpo .deps/mount-setproctitle.Po
-make -C
-make: option requires an argument -- 'C'
-Usage: make [options] [target] ...
-...
-
-Reported-by: Matthew Burgess <matthew@linuxfromscratch.org>
-Signed-off-by: Karel Zak <kzak@redhat.com>
----
-
-diff --git a/config/include-Makefile.am b/config/include-Makefile.am
-index b42a0c3..d5da619 100644
---- a/config/include-Makefile.am
-+++ b/config/include-Makefile.am
-@@ -17,6 +17,7 @@ dist_noinst_DATA = $(dist_man_MANS)
- # Paths to in-tree libraries (use ul_ prefix to avoid possible collisions)
- #
- ul_libblkid_srcdir = $(top_srcdir)/libs/blkid/src
-+ul_libblkid_builddir = $(top_builddir)/libs/blkid/src
- ul_libblkid_la = $(top_builddir)/libs/blkid/src/libblkid.la
-
- $(ul_libblkid_la):
diff --git a/meta/recipes-core/util-linux/files/gcc34.patch b/meta/recipes-core/util-linux/files/gcc34.patch
deleted file mode 100644
index 8c4a20cdca..0000000000
--- a/meta/recipes-core/util-linux/files/gcc34.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- util-linux-2.12o/disk-utils/fsck.cramfs.c~gcc34
-+++ util-linux-2.12o/disk-utils/fsck.cramfs.c
-@@ -77,15 +77,7 @@
- #define PAD_SIZE 512
-
- #include <asm/page.h>
--#ifdef PAGE_SIZE
--#define PAGE_CACHE_SIZE ((int) PAGE_SIZE)
--#elif defined __ia64__
--#define PAGE_CACHE_SIZE (16384)
--#elif defined __alpha__
--#define PAGE_CACHE_SIZE (8192)
--#else
- #define PAGE_CACHE_SIZE (4096)
--#endif
-
- /* Guarantee access to at least 8kB at a time */
- #define ROMBUFFER_BITS 13
diff --git a/meta/recipes-core/util-linux/files/glibc-fix.patch b/meta/recipes-core/util-linux/files/glibc-fix.patch
deleted file mode 100644
index 6d0c2fcefa..0000000000
--- a/meta/recipes-core/util-linux/files/glibc-fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- /tmp/cmos.c 2006-11-21 11:38:55.000000000 +0100
-+++ util-linux-2.12r/hwclock/cmos.c 2006-11-21 11:41:45.458554000 +0100
-@@ -46,15 +46,16 @@
-
- #include <unistd.h> /* for geteuid() */
- #include <fcntl.h> /* for O_RDWR */
-+#include <linux/version.h>
- #include <errno.h>
- #include "../defines.h" /* for HAVE_sys_io_h */
- #include "nls.h"
-
- #if defined(__i386__)
--#ifdef HAVE_sys_io_h
--#include <sys/io.h>
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
-+#include <asm/io.h>
- #else
--#include <asm/io.h> /* for inb, outb */
-+#include <sys/io.h> /* for inb, outb */
- #endif
- #elif defined(__alpha__)
- /* <asm/io.h> fails to compile, probably because of u8 etc */
diff --git a/meta/recipes-core/util-linux/files/optional-uuid.patch b/meta/recipes-core/util-linux/files/optional-uuid.patch
deleted file mode 100644
index 2d0ea43cd2..0000000000
--- a/meta/recipes-core/util-linux/files/optional-uuid.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From: Karel Zak <kzak@redhat.com>
-Date: Tue, 12 May 2009 19:22:19 +0000 (+0200)
-Subject: blkid: make libuuid optional
-X-Git-Url: http://git.kernel.org/?p=utils%2Futil-linux-ng%2Futil-linux-ng.git;a=commitdiff_plain;h=cdd17c7a73cab10a34bf80616225b8215ac4e2ed
-
-blkid: make libuuid optional
-
-read.c:28:23: error: uuid/uuid.h: No such file or directory
-make[3]: *** [read.lo] Error 1
-make[3]: *** Waiting for unfinished jobs....
-
-Reported-by: Olaf <mailinglists@ban-solms.de>
-Signed-off-by: Karel Zak <kzak@redhat.com>
----
-
-diff --git a/libs/blkid/src/config.c b/libs/blkid/src/config.c
-index 2e59218..9091736 100644
---- a/libs/blkid/src/config.c
-+++ b/libs/blkid/src/config.c
-@@ -24,9 +24,6 @@
- #include <errno.h>
- #endif
- #include <stdint.h>
--#ifdef HAVE_LIBUUID
--#include <uuid/uuid.h>
--#endif
- #include <stdarg.h>
-
- #include "blkdev.h"
-diff --git a/libs/blkid/src/evaluate.c b/libs/blkid/src/evaluate.c
-index a9c9fba..f0ae126 100644
---- a/libs/blkid/src/evaluate.c
-+++ b/libs/blkid/src/evaluate.c
-@@ -27,9 +27,6 @@
- #include <errno.h>
- #endif
- #include <stdint.h>
--#ifdef HAVE_LIBUUID
--#include <uuid/uuid.h>
--#endif
- #include <stdarg.h>
-
- #include "pathnames.h"
-diff --git a/libs/blkid/src/read.c b/libs/blkid/src/read.c
-index 4163874..b5e9cd0 100644
---- a/libs/blkid/src/read.c
-+++ b/libs/blkid/src/read.c
-@@ -25,7 +25,6 @@
- #endif
-
- #include "blkidP.h"
--#include "uuid/uuid.h"
-
- #ifdef HAVE_STRTOULL
- #define STRTOULL strtoull /* defined in stdlib.h if you try hard enough */
diff --git a/meta/recipes-core/util-linux/files/umount.diff b/meta/recipes-core/util-linux/files/umount.diff
deleted file mode 100644
index 78330789ef..0000000000
--- a/meta/recipes-core/util-linux/files/umount.diff
+++ /dev/null
@@ -1,19 +0,0 @@
-*** util-linux-2.12r/mount/umount.c.orig 2005-09-10 20:07:38.000000000 +0200
---- util-linux-2.12r/mount/umount.c 2006-06-07 21:14:04.000000000 +0200
-***************
-*** 40,46 ****
- #include <linux/unistd.h>
- #ifdef __NR_umount2
-
-! static int umount2(const char *path, int flags);
-
- _syscall2(int, umount2, const char *, path, int, flags);
-
---- 40,46 ----
- #include <linux/unistd.h>
- #ifdef __NR_umount2
-
-! int umount2(const char *path, int flags);
-
- _syscall2(int, umount2, const char *, path, int, flags);
-
diff --git a/meta/recipes-core/util-linux/files/uuid.patch b/meta/recipes-core/util-linux/files/uuid.patch
deleted file mode 100644
index 3208e0a865..0000000000
--- a/meta/recipes-core/util-linux/files/uuid.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: util-linux-ng-2.15/libs/blkid/src/Makefile.am
-===================================================================
---- util-linux-ng-2.15.orig/libs/blkid/src/Makefile.am 2009-05-19 17:01:15.000000000 +0100
-+++ util-linux-ng-2.15/libs/blkid/src/Makefile.am 2009-05-19 17:08:11.000000000 +0100
-@@ -7,7 +7,7 @@
- common_ldadd =
-
- if HAVE_UUID
--common_ldadd += -luuid #TODO $(UUID_LIBS)
-+common_ldadd += -luuid
- endif
-
- # includes
-@@ -26,7 +26,7 @@
- $(top_srcdir)/lib/md5.c
-
- libblkid_la_LIBADD = probers/libblkid_probers.la $(common_ldadd)
--libblkid_la_DEPENDENCIES = $(libblkid_la_LIBADD) blkid.sym
-+libblkid_la_DEPENDENCIES = probers/libblkid_probers.la blkid.sym
-
- # TODO: for unknown reason "make distcheck" requires
- # full path to the version script