aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-11-17 21:49:29 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-11-17 21:49:29 +0000
commitc5f2ff91f6fa929c12315b773421cd13b26fbb34 (patch)
treed1bca24d5915c39e4d1a5869df457534e73282fc /meta
parentb36dcf3a484000d6239d3b4f15a27768676fa373 (diff)
downloadopenembedded-core-contrib-c5f2ff91f6fa929c12315b773421cd13b26fbb34.tar.gz
u-boot-mkimage-native: Convert to use do_install for staging
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
index 38dd700d08..6922d69e07 100644
--- a/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
+++ b/meta/packages/uboot/u-boot-mkimage-native_1.3.2.bb
@@ -12,11 +12,13 @@ inherit native
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
do_compile () {
- oe_runmake smdk2410_config
- oe_runmake tools
+ oe_runmake smdk2410_config
+ oe_runmake tools
}
-do_stage () {
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage
- ln -sf ${STAGING_BINDIR_NATIVE}/uboot-mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+NATIVE_INSTALL_WORKS = "1"
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
+ ln -sf uboot-mkimage ${D}${bindir}/mkimage
}