aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-26 08:15:10 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-26 08:15:10 +0000
commit80c6eb07610e8eed91afaa5ded84596e12b10fc4 (patch)
tree12f1cc13ee37ad2668f205989988f65d55a76e57 /meta
parent38062aa45c935e4d42e342fdf69721937a643d0f (diff)
downloadopenembedded-core-contrib-80c6eb07610e8eed91afaa5ded84596e12b10fc4.tar.gz
pcmciautils: added patch (from git) to not use MODALIAS in rules as it is deprecated since udev 080
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1997 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/pcmciautils/pcmciautils-013/modalias_update.patch56
-rw-r--r--meta/packages/pcmciautils/pcmciautils_013.bb7
2 files changed, 60 insertions, 3 deletions
diff --git a/meta/packages/pcmciautils/pcmciautils-013/modalias_update.patch b/meta/packages/pcmciautils/pcmciautils-013/modalias_update.patch
new file mode 100644
index 0000000000..5727442b59
--- /dev/null
+++ b/meta/packages/pcmciautils/pcmciautils-013/modalias_update.patch
@@ -0,0 +1,56 @@
+From: Miklos Vajna <vmiklos@frugalware.org>
+Date: Fri, 3 Nov 2006 16:33:38 +0000 (-0500)
+Subject: [PATCH] fix for udev-094
+X-Git-Url: http://git.kernel.org/?p=linux%2Fpcmcia%2Fpcmciautils.git;a=commitdiff_plain;h=3a5217492c1f95711b30f4e27c51563dff6ceb3e
+
+[PATCH] fix for udev-094
+
+from udev's release notes:
+
+"udev 094
+========
+The built-in MODALIAS key and substitution is removed.
+(...)
+udev 080
+========
+(...)
+MODALIAS and $modalias is not needed and will be removed from one of
+the next udev versions, replace it in all rules with ENV{MODALIAS} or
+the sysfs "modalias" value."
+
+here is a patch to fix this issue
+
+Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
+Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
+---
+
+diff --git a/udev/rules-base b/udev/rules-base
+index c6d14de..6ed3a27 100644
+--- a/udev/rules-base
++++ b/udev/rules-base
+@@ -3,12 +3,12 @@
+ # are so broken that we need to read out random bytes of it
+ # instead of the manufactor, card or product ID. Then the
+ # matching is done in userspace.
+-ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
++ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
+ RUN+="/sbin/pcmcia-check-broken-cis"
+
+ # However, the "weak" matching by func_id is only allowed _after_ modprobe
+ # returns, so that "strong" matches have a higher priority.
+-ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
++ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
+ RUN+="/bin/sh -c 'echo 1 > /sys/$devpath/allow_func_id_match'"
+
+ # PCMCIA sockets:
+diff --git a/udev/rules-modprobe b/udev/rules-modprobe
+index ea1f44a..a13b2ad 100644
+--- a/udev/rules-modprobe
++++ b/udev/rules-modprobe
+@@ -1,3 +1,3 @@
+-# modprobe $modalias loads all possibly appropriate modules
+-ACTION=="add", SUBSYSTEM=="pcmcia", MODALIAS=="?*", \
+- RUN+="/sbin/modprobe $modalias"
++# modprobe $env{MODALIAS} loads all possibly appropriate modules
++ACTION=="add", SUBSYSTEM=="pcmcia", ENV{MODALIAS}=="?*", \
++ RUN+="/sbin/modprobe $env{MODALIAS}"
diff --git a/meta/packages/pcmciautils/pcmciautils_013.bb b/meta/packages/pcmciautils/pcmciautils_013.bb
index 8f10bb45da..5f4f4641f0 100644
--- a/meta/packages/pcmciautils/pcmciautils_013.bb
+++ b/meta/packages/pcmciautils/pcmciautils_013.bb
@@ -4,13 +4,14 @@ RDEPENDS = "udev module-init-tools"
HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmcia.html"
SECTION = "kernel/userland"
PRIORITY = "optional"
+PR = "r1"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/pcmcia/pcmciautils-${PV}.tar.bz2 \
file://makefile_fix.patch;patch=1 \
- file://version_workaround.patch;patch=1"
-S = "${WORKDIR}/pcmciautils-${PV}"
+ file://version_workaround.patch;patch=1 \
+ file://modalias_update.patch;patch=1"
-PR = "r0"
+S = "${WORKDIR}/pcmciautils-${PV}"
export HOSTCC = "${BUILD_CC}"
export etcdir = "${sysconfdir}"